Getting Started with EnSight 7.6
EN-GS Revision History

EN-GS:6.0-1       June 1997
EN-GS:6.0-2       August 1997
EN-GS:6.0-3      October 1997
EN-GS:6.0-4      October 1997
EN-GS:6.2-1     September 1998
EN-GS:6.2-2     December 1998
EN-GS:7.0-1     December 1999
EN-GS:7.1-1      April 2000
EN-GS:7.3-1      March 2001
EN-GS:7.4-1      March 2002
EN-GS:7.4-2     October 2002
EN-GS:7.6-1     May 2003

This document has been reviewed and approved in accordance with Computational Engineering International, Inc. Documentation Review and Approval Procedures.

This document should be used only for Version 7.6 and greater of the EnSight program.

Information in this document is subject to change without notice. This document contains proprietary information of Computational Engineering International, Inc. The contents of this document may not be disclosed to third parties, copied, or duplicated in any form, in whole or in part, unless permitted by contract or by written permission of Computational Engineering International, Inc. The Computational Engineering International, Inc. Software License Agreement and Contract for Support and Maintenance Service supersede and take precedence over any information in this document.

EnSight® is a registered trademark of Computational Engineering International, Inc. All registered trademarks used in this document remain the property of their respective owners.

CEI's World Wide Web addresses:
http://www.ceintl.com
or
http://www.ensight.com

Restricted Rights Legend

Use, duplication, or disclosure of the technical data contained in this document by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013. Unpublished rights reserved under the Copyright Laws of the United States. Contractor/Manufacturer is Computational Engineering International, Inc., 2166 N. Salem Street, Suite 101, Apex, NC 27523.

The data shown in the images on the front cover are courtesy of Reynard Motorsport Ltd. and the U.S. Air Force Research Laboratory at Wright-Patterson Air Force Base.
ENSIght® VERSION 7 END USER LICENSE AGREEMENT

UNLESS A SEPARATE LICENSE OR TRIAL AGREEMENT DOCUMENT EXISTS BETWEEN THE LICENSEE AND CEI OR AN AUTHORIZED CEI DISTRIBUTOR, THE TERMS AND CONDITIONS OF THIS AGREEMENT SHALL GOVERN YOUR USE OF VERSION 7 OF THE ENSIght SOFTWARE. READ THIS LICENSE CAREFULLY BEFORE USING THE ENSIght SOFTWARE. BY USING THE ENSIght SOFTWARE YOU AGREE TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT ACCEPT OR AGREE TO BE BOUND BY THE TERMS OF THIS AGREEMENT, PROMPTLY RETURN THE UNUSED ENSIght SOFTWARE WITHIN THIRTY (30) DAYS OF PURCHASE FOR A REFUND.

1. LICENSE GRANT. The Licensee is hereby granted by Computational Engineering International, Inc. (“CEI”) a single, non-transferable and non-exclusive license to use the ENSIght Software under the terms and conditions set forth below, in binary form only, and at the major release level indicated on the media used to deliver the licensed ENSIght Software.

2. DEFINITIONS.
   “Ancillary Software” includes translators, user defined data readers, tools, or other software which may from time to time be delivered with, but separate from, the “ENSIght Software”.
   “End User” means one individual running an ENSIght process.
   “ENSIght Purchase Agreement” means the document provided by Licensee to CEI which describes the type of installation Licensee is authorized to make.
   “ENSIght Documentation” means manuals, release or installation notes related to the ENSIght Software, including electronic versions thereof.
   “ENSIght Software” means all of the CEI computer programs that constitute standard ENSIght or ENSIght Gold, the ENSIght Documentation, the Third-Party Libraries (if licensed through CEI), and any backups or other copies.
   “Maximum Seats” means the maximum authorized number of End Users who may simultaneously use the licensed copy of the ENSIght Software as identified in the ENSIght Purchase Agreement.
   “Major Release Level” means all versions of the ENSIght Software which are denoted by the same integer number to the left of the first decimal point in the specification of the release. For example, all versions denoted as ENSIght 7.x are regarded as the same Major Release Level.

3. USAGE LIMITATIONS. Licensee acknowledges that the ENSIght Software is proprietary and shall remain the property of CEI. This License is not a sale. Title to and ownership of the ENSIght Software and any copies thereof, any patents, trademarks or copyrights incorporated therein and to the CEI Proprietary information shall at all times remain with CEI. No rights to rent, loan, transfer, relicense, distribute, or otherwise assign any or all of Licensee’s rights in the ENSIght Software are granted. All rights not specifically granted to Licensee by this license shall remain in CEI. CEI may include features in the ENSIght Software which prevent unlicensed use or use after license expiration. The license granted herein does not include provision of support and maintenance service or future releases or versions of the ENSIght Software.

4. INSTALLATION. ENSIght may be installed and used by the Licensee only in the manner indicated in the ENSIght Purchase Agreement. End User may use ENSIght only at his immediate workplace, unless otherwise authorized by CEI. Subject to request of and approval by CEI, Licensee may permanently or temporarily change the systems and/or networks upon which Licensee is authorized to use the ENSIght Software. In either case, such change may result in additional charges to the Licensee. Licensee may duplicate the ENSIght Software for backup, archiving, or security, provided that each copy includes all of the copyright or proprietary notices of the original. Licensee shall not clone, reverse assemble, or reverse compile any part of the ENSIght Software or adopt any part of the ENSIght Software as its own. CEI reserves the right to charge an upgrade fee for future Major Release versions of the ENSIght Software.

5. PATENTS AND COPYRIGHTS. ENSIght is copyrighted under the laws of the United States and international treaty provisions. Notwithstanding the copyright, the ENSIght Software contains trade secrets and proprietary information of CEI. Licensee acknowledges that CEI owns these copyrights and has the following exclusive rights with regard to the ENSIght Software: to reproduce it; to adapt, transform or rearrange it; to prepare derivative works from it; and to control its distribution. Licensee agrees not to act in contravention of any of CEI’s intellectual property rights.

6. ENSIght DOCUMENTATION. Licensee may use the ENSIght Documentation only in support of its use of the licensed ENSIght Software and may print or duplicate the Documentation (except any marked as proprietary), but only for its internal use and provided that each copy includes all of the copyright or related notices of the original. CEI will provide one (1) printed copy of the ENSIght “Getting Started” document with each license purchased by Licensee for the ENSIght Software. Additional printed copies of the “Getting Started” document and copies of the on-line ENSIght Documentation may be purchased from CEI.

7. WARRANTY; DISCLAIMER. CEI warrants that for a period of thirty (30) days after delivery of the ENSIght Software, it will substantially conform in all material respects to the specifications set forth in CEI’s published ENSIght Documentation. If the ENSIght Software does not meet this requirement, and Licensee notifies CEI within thirty (30) days after delivery, CEI will, at its option, repair or replace the effected ENSIght Software. This warranty excludes problems caused by acts of Licensee, unauthorized use or causes external to the ENSIght Software, and items which would be covered under Support and Maintenance service. CEI specifically does
not warrant, guarantee, or make any representations regarding the use, or the results of the use, of the EnSight Software or Documentation in terms of correctness, accuracy, reliability, currentness, or otherwise. The entire risk as to the result produced by and the performance of the EnSight Software is assumed by the End User. CEI does not warrant that the execution of the EnSight Software will be uninterrupted or error free.

CEI WARRANTS THE ANCILLARY SOFTWARE ACCORDING TO THE TERMS FOUND IN THE LICENSE_AND_WARRANTY_AND_SUPPORT FILE OF THE src DIRECTORY OF THE SOFTWARE INSTALLATION. THE ABOVE WARRANTIES ARE CEI'S ONLY WARRANTIES AND ARE IN LIEU OF ALL IMPLIED WARRANTIES, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, AND THE ABOVE REMEDIES ARE THE EXCLUSIVE REMEDIES FOR ANY BREACH OF WARRANTY. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY CEI OR ITS EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY, AND LICENSEE MAY NOT RELY ON SUCH INFORMATION OR ADVICE. LICENSEE'S SOLE REMEDY AND CEI'S SOLE OBLIGATION SHALL BE GOVERNED BY THIS AGREEMENT. LICENSEE EXPRESSLY AGREES THAT IN NO EVENT SHALL CEI BE LIABLE FOR ANY CONSEQUENTIAL, INCIDENTAL, OR SPECIAL DAMAGES ARISING FROM THE BREACH OF WARRANTY, NEGLIGENCE, OR ANY OTHER LEGAL THEORY, WHETHER IN TORT OR CONTRACT, EVEN IF CEI HAS BEEN APPRISED OF THE LIKELIHOOD OF SUCH DAMAGES OCCURRING, INCLUDING WITHOUT LIMITATION DAMAGES FROM INTERRUPTION OF BUSINESS, LOSS OF PROFITS OR BUSINESS OPPORTUNITIES, LOSS OF USE OF SOFTWARE, LOSS OF DATA, COST OF RECREATING DATA, COST OF CAPITAL, COST OF ANY SUBSTITUTE PRODUCTS, OR LOSSES CAUSED BY DELAY. FURTHER, CEI SHALL NOT BE RESPONSIBLE FOR ANY DAMAGES OR EXPENSES RESULTING FROM ALTERATION OR UNAUTHORIZED USE OF THE EnSight SOFTWARE OR FROM THE UNINTENDED AND UNFORESEEN RESULTS OBTAINED BY LICENSEE AND RESULTING FROM SUCH USE. IN ANY EVENT, CEI'S MAXIMUM LIABILITY UNDER ANY LICENSE OR OTHERWISE FOR ANY REASON SHALL NOT EXCEED THE TOTAL AMOUNT PAID BY LICENSEE FOR THE CEI EnSight SOFTWARE, EXCLUSIVE OF ANY SUPPORT AND MAINTENANCE FEES PAID. THE EXISTENCE OF MORE THAN ONE CLAIM WILL NOT ENLARGE OR EXTEND THE LIMIT.

8. THIRD-PARTY RIGHTS AND LICENSE. If Third-Party owned graphics libraries are sublicensed to Licensee by CEI, it will be so noted in the EnSight Purchase Agreement. All terms related to the EnSight Software, including and without limitation, terms related to limitation of remedies and restrictions on use, apply to the Third-Party Software.

9. LICENSE MANAGER SOFTWARE. If Licensee is authorized to install and use License Manager Software to enable the EnSight Software to execute on multiple computer systems on a network, it will be so noted in the EnSight Purchase Agreement. All terms related to the EnSight Software, including and without limitation, terms related to limitation of remedies and restrictions on use, apply to the License Manager Software. Licensees authorized to use License Manager Software may install multiple redundant license servers on the same network subnet node. Installation of multiple redundant license servers on different subnet nodes requires Licensee to submit a written request to CEI, stating that the use of multiple servers will not enable more than the maximum seats of the software to be used. Furthermore, Licensee agrees to submit License Manager log files upon request to CEI for verification. Use of EnSight on a network is restricted to one geographic location, unless otherwise authorized by CEI.

10. U. S. GOVERNMENT RESTRICTED RIGHTS. If the Licensee is the USA Department of Defense ("DOD"), the licensed EnSight Software is subject to "Restricted Rights" as that term is defined in the DOD Supplement to the Federal Acquisition Regulations ("DFARS") section 252.227-7013(c). If the Licensee is any unit or agency of the U.S. Government other than the DOD, the Government's rights in the EnSight Software will be defined in paragraph 52.227-19(c)(2) of the Federal Acquisition Regulations ("FAR"). Use, duplication, reproduction, or disclosure by the U.S. Government is subject to such restrictions. Contractor/Manufacturer is: Computational Engineering International, Inc., 2166 N. Salem Street., Suite 101, Apex, NC 27523, USA.

11. INVOICES; PAYMENT; TAXES. Licensee agrees to pay the License Fee(s) owed for this Software License as shown on a separate Invoice(s) from CEI. All Payments will be in U.S. Dollars. Payment is due within thirty (30) days after the date of each Invoice. Payment is considered made when good funds are received by CEI. To those Licensees leasing an EnSight Software License, future Invoices for the EnSight Software Lease Fee will be issued yearly in the month prior to that in which the initial payment of the EnSight Software Lease Fee was made to CEI. Licensees located in the State of North Carolina, USA are responsible for payment to CEI of all applicable State and Local sales taxes. Licensees located in any State other than North Carolina in the USA are directly responsible for payment of all import and sales taxes to the responsible government(s) at their location. Licensees located in any Country other than the USA are directly responsible for payment of all import and sales taxes to the responsible government(s) at their location. Licensees who have obtained a License through an authorized Distributor of CEI agree to comply with the Distributor's payment terms and conditions.

12. SEVERABILITY. If any provision of this Agreement shall be held by a court of competent jurisdiction to be contrary to law or not enforceable, the remaining provisions of this Agreement shall remain in full force and effect.

13. EXPORT. This License and the rights granted hereunder are subject to compliance by Licensee with all laws, regulations, orders, or other regulations relative to export or redistribution of Licensed Software that may now or in the future be imposed by the government of the United States or any agency thereof or of any other country into
which licensed EnSight Software may be transported and any act of noncompliance shall immediately terminate this License. If the Licensee imports the licensed copy of the EnSight Software into a country in which CEI has an authorized Distributor, then if the License was purchased the Licensee shall pay to CEI a Penalty Fee equal to one half the cost of the original Purchased License Fee.

14. TERM. If a License for the EnSight Software was purchased by Licensee, then this license is valid upon the date of initial payment of the Purchase License Fee to CEI by Licensee and shall continue until an event of Termination. If a License for the EnSight Software was leased by Licensee, then this license is valid for twelve (12) months from the date of initial payment of the Lease License Fee to CEI by Licensee and shall renew for subsequent twelve (12) month periods from the date Licensee pays the amounts indicated on each yearly invoice, according to Section 11, unless an event of Termination occurs.

15. TERMINATION. This Software License Agreement shall terminate upon occurrence of any of the following events: (i) the failure of Licensee to observe or perform any of the material covenants, terms, and conditions of this Agreement where such nonperformance is not fully remedied by Licensee within thirty (30) days after written notice by CEI; (ii) any breach of Sections 3, 4, 6, 7, 8, 9, or 10 hereof (effective immediately); (iii) the filing of a petition for Licensee's bankruptcy, whether voluntary or involuntary, or an assignment of Licensee's assets made for the benefit of creditors, or the appointment of a trustee or receiver to take charge of the business of Licensee for any reason, or Licensee's becoming insolvent or voluntarily or involuntarily being dissolved; or (iv) the use of a license purchased at an academic discount for purposes other than teaching or academic research. Termination of this Agreement under Section 15 shall be in addition to, and not a waiver of, any remedy at law or in equity. Notwithstanding the foregoing, the provisions of Sections 4, 6, 7, 8, 9, and 10 shall survive the termination of this agreement. Upon termination of this Software License Agreement, Licensee shall promptly cease to use and shall return to CEI all copies of the EnSight Software, the Ancillary Software, and EnSight Documentation.

16. GENERAL. Licensee may not assign or transfer its rights or obligations under this Agreement without the prior written consent of CEI. The parties agree that this Agreement shall be governed and construed by the laws of the State of North Carolina, USA, and that no conflict-of-laws provision shall be invoked to permit the laws of any other state or jurisdiction. Any legal action must be brought in the State of North Carolina, USA, and any legal action shall be governed and construed by the laws of the State of North Carolina, USA. All preprinted additional or different terms on any purchase order forms or other documents received from Licensee are deemed deleted and Licensee agrees that such terms shall be void even if the Licensee’s documentation indicates the terms therein take precedence over other documents. This Software License Agreement together with the most recent EnSight Purchase Agreement delivered to CEI by Licensee, constitutes the entire agreement of the parties and supersedes any prior understandings relating to the subject matter, and may be amended or supplemented only in a written agreement signed by both an officer of CEI and the Licensee.

17. RESTRICTION ON USE OF TrackdAPI SOFTWARE, developed and owned by VRCO Inc., an Illinois corporation, with principal place of business at 330 S. Wells Street, Suite 1200, Chicago, IL 60606; hereafter referred to as “VRCO”. Licensee is prohibited from the distribution, transfer, modification, or alteration of the TrackdAPI software and associated written materials and/or documentation (“TrackdAPI Software”) and shall abide by the following:

I. PROPRIETARY RIGHTS. Licensee agrees that its use of TrackdAPI Software is a license only and VRCO owns all right, title, and interest in the TrackdAPI Software including any patents, trademarks, trade names, inventions, copyrights, know-how and trade secrets relating to the design, manufacture, operation or service of the TrackdAPI Software. Nothing in this agreement should be construed as transferring any aspects of such rights to Licensee or any third party.

II. WARRANTY DISCLAIMER. THE LICENSED TrackdAPI Software IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OR MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LICENSED TrackdAPI Software IS ON THE LICENSEE.

III. LIMITATION OF LIABILITY. IN NO EVENT SHALL VRCO BE LIABLE FOR COSTS OF PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES OR FOR ANY SPECIAL, CONSEQUENTIAL, INCIDENTAL, OR INDIRECT DAMAGES OR LOST PROFITS ARISING OUT OF THIS AGREEMENT OR USE OF THE TrackdAPI Software, HOWEVER CAUSED, ON ANY THEORY OF LIABILITY, AND EVEN IF VRCO HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. LICENSEE AGREES VRCO’S LIABILITY ARISING OUT OF CONTRACT, NEGLIGENCE, STRICT LIABILITY IN TORT OR WARRANTY SHALL NOT EXCEED ANY AMOUNTS PAID BY LICENSEE FOR THE TrackdAPI Software IDENTIFIED ABOVE.
ENSIghT® Version 7 SUPPORT and MAINTENANCE SERVICE AGREEMENT

UNLESS A SEPARATE AGREEMENT FOR SUPPORT AND MAINTENANCE SERVICES EXISTS BETWEEN THE LICENSEE AND CEI OR AN AUTHORIZED CEI DISTRIBUTOR, THE TERMS AND CONDITIONS OF THIS AGREEMENT SHALL GOVERN CEI'S PROVISION OF AND LICENSEE'S USE OF AND PAYMENT FOR SUCH SERVICES.

1. GENERAL. The EnSight Software Licensee and Computational Engineering International, Inc., ("CEI") agree that the following terms and conditions apply to the provision of Software Support and Maintenance Service.

2. DEFINITIONS.
   "Ancillary Software" includes translators, user defined data readers, tools, or other software which may from time to time be delivered with, but separate from, the "EnSight Software".
   "EnSight Purchase Agreement" means the document provided by Licensee to CEI which describes the type of installation Licensee is authorized to make.
   "EnSight Documentation" means manuals, release or installation notes related to the EnSight Software including electronic versions thereof.
   "EnSight Software" means all of the CEI computer programs that constitute standard EnSight or EnSight Gold, the EnSight Documentation, the Third-Party Libraries (if licensed through CEI, as called out on Schedule A), and any backup or copies thereof.
   "Major Release Level" means all versions of the EnSight Software which are denoted by the same integer number to the left of the first decimal point in the specification of the release.

3. SOFTWARE SUPPORT SERVICE. During the term of this Agreement CEI will provide technical support as described below to the EnSight Software Licensee in its use of the EnSight Software, provided that Licensee has an active License to use the EnSight Software from CEI. CEI will distribute to Licensee one copy of new minor releases of the major release listed on the media used to deliver the EnSight Software including EnSight Documentation as they become available, subject to the terms and conditions of this Agreement. CEI may modify the terms, conditions, and prices for services applicable to future major releases.

4. SOFTWARE MAINTENANCE SERVICE. During the term of this Agreement CEI will maintain the EnSight Software provided that Licensee has an active License to use the EnSight Software from CEI. CEI will distribute to Licensee one copy of new minor releases of the major release listed on the media used to deliver the EnSight Software including EnSight Documentation as they become available, subject to the terms and conditions of this Agreement. CEI may modify the terms, conditions, and prices for services applicable to future major releases.

5. EXCLUDED SOFTWARE. NO SUPPORT OR MAINTENANCE SERVICE FOR THE ANCILLARY SOFTWARE IS OFFERED OR PROVIDED BY THIS AGREEMENT EXCEPT AS NOTED IN THE LICENSE_AND_WARRANTY_AND_SUPPORT FILE OF THE src DIRECTORY OF THE SOFTWARE INSTALLATION.

6. LICENSEE AGREEMENTS FOR SOFTWARE SUPPORT AND SOFTWARE MAINTENANCE. In order to permit CEI to supply the Software Support and Software Maintenance specified above:
   (i). If third party graphic libraries accompanied the EnSight Software delivered to Licensee, as noted in the EnSight Purchase Agreement, and such third party issues a new version of such library software which CEI incorporates into the Software, then Licensee must comply with any additional licensing or fee requirements imposed by such third party.
   (ii). Licensee agrees to install minor releases, fixes, circumventions, and corrective code to the EnSight Software in a reasonable time after receipt thereof.
   (iii). Licensee agrees to be responsible for the installation and administration of the EnSight Software.
   (iv). Upon request by CEI, Licensee will provide the name, address, telephone and FAX number, and Email address (if available) of the Licensee’s contact individual for communicating problems and solutions.

7. FEES. If Licensee is Leasing an EnSight Software License, then the cost of the Software Support and Maintenance Service is included in the annual EnSight Software License Fee. If Licensee has Purchased an EnSight Software license, then there is no separate fee for Software Support and Maintenance Service for a period of twelve (12) months from the date of the initial payment of the EnSight Software License Purchase Fee to CEI. Licensee agrees to subsequently pay the annual EnSight Software Support and Maintenance Service Fee(s) for subsequent twelve (12) month periods at the then current rates when invoiced. If an additional yearly charge for Support and Maintenance Service for third-party graphics libraries of license manager software accompanying the EnSight Software is required, Licensee agrees to pay the additional charges at the same time and at the then current rates.

Licensees located in any State other than North Carolina in the USA are directly responsible for payment of all State and Local taxes applicable at their location for this Service. Licensees located in
any Country other than the U.S. are directly responsible for payment of all taxes to the government(s) at their location for this Service. Licensees who have obtained a License through an authorized Distributor of CEI agree to comply with the Distributor’s payment terms and conditions.

8. LIMITATION OF REMEDY AND DISCLAIMER. CEI WILL USE ITS DILIGENT EFFORTS TO PROVIDE THE SUPPORT AND MAINTENANCE SERVICES SPECIFIED HEREIN. CEI MAKES NO OTHER WARRANTY OF ANY KIND OR NATURE WITH REGARD TO THE SERVICES TO BE PERFORMED BY CEI UNDER THE TERMS OF THIS AGREEMENT AND ANY IMPLIED WARRANTIES, INCLUDING THE IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR PURPOSE AND MERCHANTABILITY, ARE HEREBY DISCLAIMED. THE REMEDIES SET FORTH IN THIS AGREEMENT ARE LICENSEE’S EXCLUSIVE REMEDIES FOR ANY BREACH OF THE TERMS OF THIS AGREEMENT. CEI WILL NOT BE LIABLE IN ANY EVENT FOR LOSS OF OR DAMAGE TO REVENUES, PROFITS, OTHER ECONOMIC LOSS OR GOODWILL OR OTHER CONSEQUENTIAL, SPECIAL, INCIDENTAL OR INDIRECT DAMAGES ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF ITS OBLIGATIONS HEREUNDER, INCLUDING ANY LIABILITY FOR NEGLIGENCE WITH RESPECT TO SERVICE PROVIDED UNDER THIS AGREEMENT EVEN IF CEI HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN ANY AND ALL CASES, CEI’S MAXIMUM LIABILITY IN CONNECTION WITH OR ARISING OUT OF THIS AGREEMENT SHALL NOT EXCEED THE EQUIVALENT OF ONE (1) YEAR OF CHARGES FOR THE RELEVANT SERVICE. THE EXISTENCE OF MORE THAN ONE CLAIM WILL NOT ENLARGE OR EXTEND THE LIMIT.

9. INVOICES AND PAYMENT. To those Licensees who have purchased an EnSight Software License, future Invoices for the EnSight Software Support and Maintenance Fee(s) will be issued yearly in the month prior to that in which the initial payment of the EnSight Software License Purchase Fee was made to CEI. Invoices shall be due and payable within thirty (30) days of date of invoice. All payments will be in U. S. Dollars. Payment of invoice is considered made when good funds are received by CEI.

10. OBSOLETE PRODUCTS. CEI will continue to provide Software Support Service for the release prior to the most current release for a period of twelve (12) months after the release date of the most current release. At that time, the previous release is designated as Obsolete and Software Support Service for the Obsolete release shall thereafter be discontinued.

11. TERM. The Term of this Agreement shall be from the date payment from Licensee is first received by CEI for the EnSight Software License Purchase Fee or the EnSight Software License Lease Fee, whichever is applicable, until an event of Termination.

12. TERMINATION. EnSight Software Support and Software Maintenance Service hereunder may be terminated as follows: (A) by Licensee or CEI to be effective during or after the first year of such Service upon giving ninety (90) days written notice; (B) by CEI with respect to Obsolete Products; (C) by CEI immediately and without notice, with respect to the EnSight Software, the license for which has expired or been terminated; (D) by CEI after ten (10) days subsequent to providing notice to Licensee upon either (i) nonpayment by Licensee of any Invoiced amount due under this Agreement or the EnSight End User License Agreement; or (ii) nonperformance by Licensee of any other material term or condition of this Agreement.

13. ASSIGNMENTS. The Licensee may not assign or transfer its rights or obligations under this Agreement, in whole or in part, without the written consent of CEI.

14. APPLICABLE LAW. The parties agree that this Agreement shall be governed and construed by the laws of the State of North Carolina, USA, and that no conflict-of-laws provision shall be invoked to permit the laws of any other state or jurisdiction. Any legal action must be filed within one (1) year after the cause for such action arises with the court of jurisdiction in the State of North Carolina, USA.

15. GENERAL. The terms and conditions stated in this Agreement constitute the complete and exclusive statement of the Agreement between Licensee and CEI and supersede all prior oral and written statements of any kind whatsoever made by either party or their representatives.

All preprinted additional or different terms on any purchase order forms or other documents received from Licensee are deemed deleted and Licensee agrees that such terms shall be void even if the Licensee’s documentation indicates the terms therein take precedence over other documents. All waivers of or amendments to the terms and conditions of this Agreement, to be effective, must be in writing and signed by an officer of CEI and Licensee.

CEI Address:
Computational Engineering International, Incorporated
2166 N. Salem Street, Suite 101, Apex, North Carolina 27523
USA
# Table of Contents

## Introduction

## 1 Installation For Unix Systems

### 1.1 Installation
- Mounting the CD-ROM Drive ............................................. 1-5
- Mounting the CD-ROM Drive on an HP system ......................... 1-6
- Installation for Systems with Attached CD-ROM Drives ............. 1-6
- Installation for Systems without Attached CD-ROM Drives ......... 1-7
- Post Installation Instructions ........................................... 1-8
- Installing the EnSight License Keys ................................... 1-10

### 1.2 Troubleshooting the Installation ................................... 1-13
### 1.3 Verifying the Installation ........................................... 1-14
- Starting EnSight for Stand-alone Use ................................ 1-14
- Starting EnSight for Distributed Use ................................ 1-14

### 1.4 Troubleshooting the Connection .................................... 1-16
### 1.5 Where’s the Rest? ..................................................... 1-17

## 2 Installation For Windows Systems

### 2.1 Installation ............................................................ 2-3
- Installation Procedure .................................................... 2-3
- Post Installation Instructions ............................................ 2-3
- Installing the EnSight License Keys ................................... 2-4

### 2.2 Troubleshooting the Installation .................................... 2-7

### 2.3 Verifying the Installation ............................................ 2-8
- Starting EnSight for Stand-alone Use ................................ 2-8
- Starting EnSight for Distributed Use ................................ 2-8

### 2.4 Troubleshooting the Connection .................................... 2-10
### 2.5 Where’s the Rest? ..................................................... 2-11
# Table of Contents

## 3 EnSight Graphical User Interface

- 3.1 Tour of the GUI .................................................. 3-2
- 3.2 User Interface Conventions ................................ 3-8
- 3.3 Where’s the Rest? ................................................. 3-13

## 4 Simple Demonstration

- 4.1 Starting EnSight .................................................. 4-2
  - Starting EnSight for Stand-alone Use .......................... 4-2
  - Starting EnSight for Distributed Use ......................... 4-2
  - Distributed Use - Automatic Connection .................... 4-4
- 4.2 Reading a Dataset ............................................... 4-5
  - Getting Your Data Into EnSight ............................... 4-7
- 4.3 Performing Transformations .................................. 4-9
  - EnSight Hot Keys .................................................. 4-12
- 4.4 Creating and Manipulating Viewports ....................... 4-13
- 4.5 Parts and Part Attributes ..................................... 4-15
- 4.6 Using Online Help .............................................. 4-20
- 4.7 Exiting EnSight .................................................. 4-22
- 4.8 Where’s the Rest? ................................................. 4-23

## 5 Flow Visualization Example: Unstructured Mesh

- 5.1 Starting EnSight .................................................. 5-2
  - Starting EnSight for Stand-alone Use .......................... 5-2
  - Starting EnSight for Distributed Use ......................... 5-2
  - Distributed Use - Automatic Connection .................... 5-4
- 5.2 Reading a Dataset ............................................... 5-5
- 5.3 Feature Demonstration .......................................... 5-7
- 5.4 Saving Files ...................................................... 5-18
  - Saving Images ..................................................... 5-18
  - Saving Commands to a File ................................... 5-19
  - Saving an Archive ................................................ 5-20
- 5.5 Where’s the Rest? ................................................. 5-21
## 6 Flow Visualization Example: Structured Mesh

6.1 Starting EnSight ......................................................... 6-2
   Starting EnSight for Stand-alone Use ................................ 6-2
   Starting EnSight for Distributed Use .................................. 6-2
   Distributed Use - Automatic Connection .............................. 6-4

6.2 Reading a Dataset ..................................................... 6-5

6.3 Feature Demonstration ................................................. 6-8

6.4 Where’s the Rest? ....................................................... 6-12

## 7 Structural Mechanics Example

7.1 Starting EnSight ......................................................... 7-2
   Starting EnSight for Stand-alone Use ................................ 7-2
   Starting EnSight for Distributed Use .................................. 7-2
   Distributed Use - Automatic Connection .............................. 7-4

7.2 Reading a Dataset ..................................................... 7-5

7.3 Feature Demonstration ................................................. 7-7

7.4 Annotation .......................................................... 7-12

7.5 Flipbook Animation .................................................. 7-16

7.6 Where’s the Rest? ....................................................... 7-17

## 8 Where Do I Go From Here?

Index
Introduction

What’s in Getting Started?

This *Getting Started* manual contains the following information:

- Installation (and verification) instructions (Chapters 1 and 2).
- An introduction to the EnSight user interface (Chapter 3).
- Some simple, step-by-step demonstrations of basic EnSight functionality (Chapters 4–7).

Conventions Used in Getting Started

The following typographic conventions are used in the *Getting Started* manual:

A numbered step tells you exactly what to do:

1. Change the value to “0.0” and press return.

UNIX and DOS level commands are denoted in a fixed-width font. Never type the leading “%” – it indicates that the command is to be issued at a shell prompt.

   `% ensight7.client -cm`

Menu selections use “>” to indicate the selection hierarchy. For example, “Tools > Plane > Line” means to select Plane from the Tools menu and then select Line from the Plane cascade menu.

Notes and warnings provide particularly important information:

*Note: Text emphasized in this fashion is a note.*

*Warning: Text emphasized in this fashion is a warning. Warnings typically indicate that your actions may have unintended consequences.*
Where’s the Rest?

The remainder of the EnSight documentation (as well as a version of this manual) is available online. The other documentation is divided into three manuals:

**How To**

The How To documentation consists of relatively short articles that describe how to perform a specific operation in EnSight, such as change the color of an object or create an isosurface. Step-by-step instructions and pictures of relevant dialogs are included. In addition, each How To article typically contains numerous hyperlinks (colored blue) to other related articles (and relevant sections of the User Manual).

To access a list of the online How To articles, select Help > How To Manual.... From this location you can easily navigate to any of the articles or to a comprehensive index.

**User Manual**

The User Manual provides a detailed reference for EnSight.

To access the User Manual, select Help > User Manual.... From this location you can easily navigate to any of the chapters, the table of contents, or a comprehensive index.

*Note: When navigating in the online User Manual, you can easily return to the User Manual Table Title Page by clicking on the footer text: EnSight 7 User Manual.*

**Command Language Manual**

The Command Language Manual provides details for each command of the command language used in EnSight. Note that this is an advanced manual which is generally not needed by most users.

To access the Command Language Manual, select Help > Command Manual.... From this location you can easily navigate to the table of contents or a comprehensive index.

*Note: When navigating in the online Command Language Manual, you can easily return to the Command Language Manuel Title Page by clicking on the footer text: EnSight 7 Command Language Manual.*
1 Installation For Unix Systems

EnSight is a powerful software package for the postprocessing, visualization, and animation of complex datasets. One of the unique features of EnSight is its ability to run distributed, sharing the workload between a Server process (handling data I/O and all compute intensive functions) and a Client process (managing user-interface interaction and graphic rendering). The EnSight Client and Server can either run on the same computer system (stand-alone operation) or the Client can run on a workstation and the Server can run on a remote computer system (distributed operation).

**Important:** The EnSight client is designed to run on a user’s workstation. It is not designed to run on a remote machine due to its interaction with the windowing system and graphics hardware. If it is run on a remote machine, performance will suffer and rendering errors may occur.

If you are installing EnSight for a trial evaluation, you will be provided with a license key file which permits you to install and execute EnSight in either stand-alone or distributed mode on any computer system at your site for a limited amount of time.

If you have purchased or are leasing a license for EnSight, have chosen to run distributed, and always intend to run the Client processes on the same workstation(s), the easiest method of installation will be to node-lock the Clients to that (those) workstation(s). If however you anticipate running the Client process from a number of different workstations at different times, (the maximum number of concurrent EnSight processes is governed by the number of seats for which you are licensed) then you will need to install the *EnSight License Manager*.

### What You’ll Need For Installation

To install and run EnSight, you will need:

1. A CD-ROM drive attached to a UNIX system.
2. A computer system capable of running the EnSight Client and/or Server. See Table 1 below for a list of supported EnSight platforms.
3. If you plan to run EnSight distributed, your networking environment must support the TCP/IP network protocol. If you can run `telnet` from the Client to the Server host system, you have TCP/IP installed. If you have questions, consult your local system administrator.
4. A valid EnSight license key. If the key information was not included with your materials, it will be sent via FAX or email.
5. Sufficient disk space. Approximately 300 MB will be required, depending on how many architectures are installed. Data files, some printable documentation, and some executables can be removed after installation to save space.
6. Sufficient memory. A minimum of 128 MB of memory is recommended for typical usage. If you work with large datasets you will require more.
Per-platform notes:

**SGI**  
IRIX 6.5 is required. SGI periodically releases various patches to the IRIX system software. It is vital that all recommended patches be installed for proper EnSight operation. SGI provides patches free over the Internet: see http://support.sgi.com.

**Sun**  
Solaris 2.8 is required. EnSight uses the OpenGL libraries provided by Sun for 3D graphics support for the EnSight Client. These libraries are provided for Solaris 2.5.1 or greater. Execute the following to determine if the libraries are installed:

```bash
% ls -l /usr/openwin/lib/libGL.so
```

If the response indicates that there is “no such file ...” the OpenGL libraries are *not* installed. Contact Sun for information on how to obtain the libraries. Sun’s OpenGL libraries support essentially all of the available graphics systems that Sun has produced over the past few years. However, only the Creator3D and later boards provide hardware graphics support. Since other boards emulate the graphics in software, performance will be quite limited.

Note that EnSight will only run under the Common Desktop Environment (CDE).

**HP**  
HP-UX 11.00 is required. If you are running an earlier OS level, you *must* upgrade in order to run EnSight 7.

**Compaq**  
Tru64 Unix v5.1 is required. If you are running an earlier OS level, you *must* upgrade in order to run EnSight 7.

**IBM**  
AIX 5.1 is required. If you are running an earlier OS level, you *must* upgrade in order to run EnSight 7. In addition, you must enable your X server to support OpenGL. See *Post Installation Instructions* on page 1-8 for details.

**Linux**  
RedHat 6.x and RedHat 7.x have been tested - other distributions based on the Linux 2.4 kernel may work also.

*Supported operating system levels and platforms are subject to change. The most recent information can be obtained from our website:*

www.ensight.com/products/hardware.html
Note: All clients require OpenGL for hardware accelerated graphics performance. Software OpenGL emulation is available through the X client (ensight7 -X) Supported operating system levels and platforms are subject to change. The most recent information can be obtained from our website: www.ensight.com/products/hardware.html

<table>
<thead>
<tr>
<th>Vendor</th>
<th>Supported OS Level / Processors</th>
</tr>
</thead>
<tbody>
<tr>
<td>SGI</td>
<td>IRIX 6.5 (32 or 64 bit)</td>
</tr>
<tr>
<td>HP</td>
<td>HPUX 11.00 (32 or 64 bit)</td>
</tr>
<tr>
<td></td>
<td>PA-RISC processors</td>
</tr>
<tr>
<td>HP</td>
<td>HPUX 11.20 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>IA-64 processors</td>
</tr>
<tr>
<td>Sun</td>
<td>Solaris 2.8 (32 or 64 bit)</td>
</tr>
<tr>
<td></td>
<td>Spare processors</td>
</tr>
<tr>
<td>Compaq</td>
<td>Tru64 Unix v5.1 (64 bit)</td>
</tr>
<tr>
<td></td>
<td>Alpha Processors</td>
</tr>
<tr>
<td>IBM</td>
<td>AIX 5.1 (32 or 64 bit)</td>
</tr>
<tr>
<td></td>
<td>Power processors</td>
</tr>
<tr>
<td>Linux</td>
<td>Kernel 2.4</td>
</tr>
<tr>
<td></td>
<td>X86 (32 bit), X86-64 (64 bit), IA-64 (64 bit)</td>
</tr>
<tr>
<td>Microsoft</td>
<td>Windows 2000/XP</td>
</tr>
<tr>
<td></td>
<td>X86 (32 bit)</td>
</tr>
</tbody>
</table>

Table 1: Supported EnSight Platforms.
For users with a CD-ROM drive attached to the system on which EnSight will be installed, the instructions can be summarized as follows:

1. Insert the CD-ROM.
2. Mount the CD-ROM drive.
3. Select an installation directory.
4. Execute the installation script and follow the instructions.
5. Execute any required post-installation steps.
6. Set up the required license key(s) for your environment.
7. If the Client seats are floating, start the EnSight License Manager.

If you do not have a CD-ROM attached to the system on which EnSight will be installed, the following steps apply:

1. Insert the CD-ROM on a system with a CD-ROM drive.
2. Mount the CD-ROM drive.
3. Select a temporary installation directory.
4. Execute the installation script and follow the instructions.
5. Pack up the installed files, move them to the desired host, and unpack.
6. Execute any required post-installation steps.
7. Set up the required license key(s) for your environment.
8. If the Client seats are floating, start the EnSight License Manager.

Should you encounter problems in your installation or use of EnSight, please contact CEI support:

Email: support@ensight.com
Hotline: 800-551-4448 (U.S)
919-363-0883 (Non-U.S.)
Fax: 919-363-0833
1.1 Installation

The installation instructions are divided into the following five sections:

- Mounting the CD-ROM and Mounting the CD-ROM on an HP System
- Installing on systems with an attached CD-ROM drive
- Installing on systems without an attached CD-ROM drive
- Post installation instructions
- Installing the EnSight license key

Mounting the CD-ROM Drive

*Note: For mounting the CD on an HP system, see the next section.*

1. The EnSight CD was written under ISO9660 using Rockridge extensions. Insert the EnSight CD into the CD-ROM drive. The drive must either be attached to the system on which EnSight will be installed OR be attached to a machine that is accessible (over the network) from the desired installation machine.

On many machines, the CD-ROM drive is mounted automatically when a disk is inserted. To check for this, execute the `df` command. On many SGI systems, the CD-ROM will be automatically mounted on `/CDROM`. On a Sun system running `vold`, the CD-ROM will be mounted on `/cdrom/cdrom0`.

The directory on which the CD-ROM is mounted will be referred to as `CDROM_DIR`. If the CD-ROM is mounted, proceed to the next section.

2. If you do not see the CD-ROM mounted, you will have to mount it manually (or consult your local system administrator). To mount it manually (note that you will require root permission to perform this operation):

   ```
   mkdir /cdrom
   ```

3. Execute the applicable mount command for your system. Note that the actual device name (the parameter after the “-r” flag) will depend on how your system is set up.

   *Note: The commands shown below are only examples. The actual command for your system will depend on your platform, OS level, and system setup. See the man page on `mount` or your local system administrator for more information.*

<table>
<thead>
<tr>
<th>System</th>
<th>Sample Mount commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>SGI</td>
<td><code>/sbin/mount -t iso9660 -r /dev/rdsk/dks1d4vol /cdrom</code></td>
</tr>
<tr>
<td>Sun</td>
<td><code>/sbin/mount -f hsfs -r /dev/dsk/c0t6d0s0 /cdrom</code></td>
</tr>
<tr>
<td>Compaq</td>
<td><code>/usr/sbin/mount -t cdfs -r -o rrip /dev/rdz4c /cdrom</code></td>
</tr>
<tr>
<td>IBM</td>
<td><code>/usr/sbin/mount -v cdrfs -r /dev/cd0 /cdrom</code></td>
</tr>
<tr>
<td>Linux</td>
<td><code>mount /mnt/cdrom</code></td>
</tr>
</tbody>
</table>
Mounting the CD-ROM Drive on an HP system

1. Insert the EnSight CD into the CD-ROM drive. The drive must either be attached to the system on which EnSight will be installed OR be attached to a machine that is accessible (over the network) from the desired installation machine.

2. The EnSight CD was written under ISO9660 using Rockridge extensions, so you must mount the CD using pfs_mount:

   % pfs_mountd &
   % pfsd 4 &
   % pfs_mount -t rrip -x unix /dev/dsk/c0t0d0 /cdrom

   Note: pfs_mount has a bug. If you see the error message “pfs_mount: Not owner”, or “pfs_mount: giving up on /cdrom” you must edit /etc/group and make sure that root belongs to 8 or less groups. If not, you must take root out of some of the groups to meet this condition, then logout and back in to try mounting again.

Installation for Systems with Attached CD-ROM Drives

If your CD-ROM drive is attached to the system on which you wish to install EnSight, then perform the steps described here. If not, then skip to the next section.

1. Select an installation directory. A typical choice is /usr/local. In the discussion below, this directory will be referred to as INSTALL_DIR. Be sure you have write permission (and sufficient disk space) in this directory before proceeding. If the directory is write protected, you may require root (superuser) status to perform the install.

2. Be sure the CD is inserted and change the directory to CDROM_DIR (be sure to replace CDROM_DIR with the directory on which your CD-ROM is mounted as described in the previous section):

   % cd CDROM_DIR

   On an HP system:

   % cd /cdrom

3. Execute the installation script:

   % ./install_unix

4. If you do not wish to install the software in /usr/local, change the install directory using choice “98” on the install menu.

5. The install script lists the various components on the CD. Choose the option to install EnSight.

6. The EnSight installation menu will present a list of components. You probably want choice “98” which will install the software together with documentation and examples. Following this choice you will be presented with a list of architectures to install. To save disk space, you do not need to install the documentation on systems intended to run only the EnSight Server. The documentation is required on any systems that will run the EnSight Client. You may also save disk space by not installing the extra example data sets.

7. After installing the needed architectures, choose “99” to go back a menu to either install more components, or to again choose “99” to return to the main install menu.

8. Simple License Manager (SLiM) will automatically be installed for the architectures selected in step 6. Should you have a floating key and wish to run the SLiM on a different system, please see section “Installing the EnSight License Keys”.

9. You do not need to install EnLiten or EnVideo manually as these components are automatically installed when you install EnSight.

Proceed to Post Installation Instructions on page 1-8.
Installation for Systems without Attached CD-ROM Drives

If you wish to install EnSight on a system that does not have an attached CD-ROM drive, then perform the steps described here. Two machines are discussed here: the system on which EnSight will be installed (referred to as INSTALL_HOST) and the system on which the CD-ROM drive is attached (referred to as CDROM_HOST).

1. On CDROM_HOST, select a temporary installation directory. In the discussion below, this directory will be referred to as TMP_INSTALL_DIR. Be sure you have write permission (and sufficient disk space) in this directory before proceeding. If the directory is write protected, you may require root (superuser) status to perform the install.

2. Be sure the CD is inserted and change directory to CDROM_DIR (be sure to replace CDROM_DIR with the directory on which your CD-ROM is mounted as described in the section above Mounting the CD-ROM Drive):

   % cd CDROM_DIR

   On an HP system:
   % cd /cdrom

3. Execute the installation script:

   % ./install_unix

4. Follow instructions 4 through 9 outlined in the previous section (Installation for Systems with Attached CD-ROM Drives).

5. Change directory to TMP_INSTALL_DIR:

   % cd TMP_INSTALL_DIR

6. Pack up the distribution files using the tar command and compress:

   % tar -cvf CEI.tar CEI
   % compress CEI.tar

7. On INSTALL_HOST, select an installation directory. A typical choice is /usr/local. In the discussion below, this directory will be referred to as INSTALL_DIR. Be sure you have write permission (and sufficient disk space) in this directory before proceeding. If the directory is write protected, you may require root (superuser) status to perform the install.

8. Copy the CEI.tar.Z file from CDROM_HOST to the INSTALL_DIR directory you just created on INSTALL_HOST. This can be accomplished using ftp or some other file transfer mechanism. Unless you wish to install on additional systems, you can remove TMP_INSTALL_DIR/CEI.tar.Z from CDROM_HOST.

The remaining steps are performed on INSTALL_HOST.

9. On INSTALL_HOST, change directory to INSTALL_DIR:

   % cd INSTALL_DIR

10. Unpack and remove the tar file:

    % zcat CEI.tar.Z | tar -xvf -
    % rm CEI.tar.Z

11. Be sure permissions are set correctly:

    % cd CEI
    % ./set_permissions

Proceed to the next section.
Installation

Post Installation Instructions

Adobe Acrobat .pdf files for local printing of all EnSight 7 documentation were installed in the INSTALL_DIR/CEI/ensight76/doc/Manuals directory (see Printing the documentation on page 4-21 for more information).

All Users

All users (no matter what shell interpreter is used) must add the following commands to their ~/.cshrc file. Be sure to replace INSTALL_DIR with the appropriate value.

```bash
setenv CEI_HOME INSTALL_DIR/CEI
set path = ( $path ${CEI_HOME}/bin )
```

You will have to log out and back in again for these changes to take effect.

Existing EnSight users please read the Note: on next page.

The environment variable has the following meaning:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>CEI_HOME</td>
<td>The CEI installation directory.</td>
</tr>
</tbody>
</table>

In addition, setting the following environment variables can change EnSight’s behavior:

- **CEI_ARCH**
  - The start scripts for EnSight automatically detect the architecture of the machine you are using. To override this auto detection you can select a specific executable by setting this environment variable. For example, on an SGI system, EnSight may automatically select the 64-bit executables, sgi_6.5_n64. To override this and use the 32-bit executables instead, you can set:
    ```bash
    setenv CEI_ARCH sgi_6.5_n32.
    ```
  - This will cause the 32-bit executables in ${CEI_HOME}/ensight76/machines/sgi_6.5_n32 to be used.

- **ENSIGHT7_INPUT**
  - A dynamic input device library to load with EnSight. May be set to an input device name (i.e. polhemus) to load from ${CEI_HOME}/ensight76/machines/${CEI_ARCH}/lib_input or to a full path name to load from a user-specified location.

- **ENSIGHT7_READER**
  - A directory which contains additional user-defined readers to be loaded before any user-defined readers that are part of the EnSight distribution. If you need this capability, please see the README file in ${CEI_HOME}/ensight76/src/readers/ for more information.

- **ENSIGHT7_UDW**
  - A directory which contains additional user-defined writers to be loaded before any user-defined writers that are part of the EnSight distribution. If you need this capability, please see the README file in ${CEI_HOME}/ensight76/src/writers/ for more information.
ENSIGHT7_MAX_THREADS
The maximum number of threads to use for each EnSight server. Threads are used to accelerate the computation of streamlines, clips, isosurfaces, and other compute-intensive operations. At this time threads are supported on all systems that run EnSight. A maximum of 2 threads may be used with a Standard license, while 128 threads are allowed with a Gold license.

ENSIGHT7_MAX_CTHREADS
The maximum number of threads to use for each EnSight client. The same 2 thread limitation applies for a Standard license.

ENSIGHT7_MAX_SOSTHREADS
The maximum number of threads to use for each EnSight server-of-servers. As the server-of-servers is a Gold feature, the limit for threads is 128.

**Bourne Shell Users**
For Bourne Shell (/bin/sh) users, the following commands must be added to their ~/.profile file. Be sure to replace INSTALL_DIR with the appropriate value.

```
CEI_HOME=INSTALL_DIR/CEI
export CEI_HOME
PATH=$PATH:${CEI_HOME}/bin
export PATH
```

You will have to log out and back in again for these changes to take effect.

**Platform-specific settings**

**IBM**
The X Server must be started with the OpenGL extension. There are a number of ways this can be done under the Common Desktop Environment. See /usr/lpp/OpenGL/README for information.
**Installing the EnSight License Keys**

You should have received an EnSight license key file from your EnSight representative. (If not, please contact CEI or your local distributor of EnSight). The following provides a brief overview of the EnSight keying mechanism. The information provided is not critical to the installation process: you can skip it or return to it later if desired.

**Keying Overview**

The EnSight Client software can be installed either *node-locked* or *floating*. The choice for your installation was made when you purchased EnSight or requested a trial evaluation.

In a node-locked EnSight Client installation, the systemID numbers for all EnSight Client systems were provided to CEI. The Client will read the license key file (*slim7.key*) to determine if it is running on a licensed host. The key file also contains information on the licensing company and expiration date.

*Note:* If you are installing for a trial evaluation, you will normally be installing EnSight as node-locked. Trial installations will use a key file which allows node-locked operation on any computer system at your site for a limited time.

The advantage of a node-locked EnSight Client installation is that it is simple to install – only the *slim7.key* file is required. The disadvantage is that you will only be permitted to run the EnSight Client on those workstations for which you have submitted systemID numbers.

If you have purchased or are leasing an EnSight license, you have the additional option of a floating EnSight Client installation in which the Client reads the *slim7.key* file as before. However, the file now contains information concerning which IP networks are valid for the license. In addition, the number of permitted seats (concurrent executions) is tracked using the EnSight’s *Simple License Manager* (or SLiM). The advantage of a floating EnSight Client installation is that EnSight can be executed from any workstation within the given IP network as long as the maximum seat count has not been exceeded. The disadvantage is that a system daemon (*slimd*) must be installed and run in order to track the seat count.

**Key Installation**

The contents of the *slim7.key* file are provided by your EnSight representative.

*Note:* All machines which will execute the EnSight Client must have access to the key file. The Client process will always look for the file in the *${CEI_HOME}/license* directory.

1. Change directory to the license subdirectory:
   
   ```
   % cd INSTALL_DIR/CEI/license
   ```

2. Create the *slim7.key* file by doing either a) or b):
   
   a. If you received your key contents via email, use a text editor (*e.g.* vi or emacs) to create the file *slim7.key*, then copy into it the appropriate contents from the email, save the file, and exit the editor.
   
   b. If you did not receive the key contents by email, you will have to type them from the printed information you have received. Using a text editor (*e.g.* vi or emacs), create the file *slim7.key*. Enter the text exactly as shown – in particular be careful with uppercase O and zero (0). Save the file and exit the text editor.

   Be sure the *slim7.key* file is readable by all users of EnSight. Execute:

   ```
   % chmod 644 slim7.key
   ```
If you are installing a node-locked license, your installation is complete. You should now proceed to Verifying the Installation on page 1-14. If you encountered problems, please consult Troubleshooting the Installation on page 1-13 before contacting CEI support.

If you are installing EnSight’s Simple License Manager, continue. Your designated host system will act as your license manager server and is referred to here as LM_HOST. The slim7.key file contains a slimd line that describes LM_HOST (the third word on the line is the name of the system). Most installations will run a single copy of the EnSight License Manager and will therefore have only one slimd line. However, it is possible to run multiple (redundant) license managers. If this was requested, your slim7.key file will have a slimd line for each host. Execute the following steps for each host, replacing LM_HOST as appropriate.

1. Log on to LM_HOST.

   **Note:** Installing EnSight will automatically install SLiM for the selected EnSight architectures. Should you wish to install SLiM separately to a different directory or for a different architecture, rerun the installation script on the EnSight CD and install the SLiM license manager.

2. Change directory to the license subdirectory:

   ```
   % cd INSTALL_DIR/CEI/license
   ```

3. Create the file slim7.key by doing either a) or b):

   a. If you received your key contents via email, use a text editor (e.g. vi or emacs) to create the file slim7.key, then copy into it the appropriate contents from the email, save the file, and exit the editor. If the machine on which you created the file is not the same as LM_HOST, you must move (using ftp or some other file transfer mechanism) slim7.key to the directory $CEI_HOME/license on LM_HOST.

   b. If you did not receive the key contents by email, you will have to type them from the printed information you have received. Using a text editor (e.g. vi or emacs), create the file slim7.key. Enter the text exactly as shown – in particular be careful with uppercase O and zero (0). Save the file and exit the text editor.

4. The EnSight License Manager server will listen for connections on the socket port number given as the first number on the applicable slimd line of the slim7.key file. If you did not specify a desired port number when you requested your key, port number 7790 is used. If this number conflicts with other usage at your site, you CANNOT change the key file – contact CEI for a new key.

5. Start the EnSight License Manager daemon. (Note that you must have set $CEI_HOME and the path to the bin directory, as explained in the Post Installation Instructions, for these scripts to work – even if all you are installing is the license manager.)

   ```
   % slimd_start
   ```

6. To check that the daemon is running properly:

   ```
   % slimd_status
   ```

   The output should indicate that “slimd is running”. The Simple License Manager (SLiM) is now running (if not, see Troubleshooting the Installation on page 1-13). If you need to stop the daemon at any time, execute slimd_stop.
If the license manager host is rebooted, the daemon will need to be restarted. On systems that are restarted infrequently, this is not a problem. However, you may want to consider adding the `slimd_start` program to your system’s boot procedures (remember to set `${CEI_HOME}` prior to executing `slimd_start`). Consult your local system administrator for assistance.

This completes the installation process. You should now proceed to *Verifying the Installation* on page 1-14. If you encountered problems, please consult *Troubleshooting the Installation* on page 1-13 before contacting CEI support.

Additional information regarding SLiM can be found in `${CEI_HOME}/license/README.TXT`.

**Note:** If you are currently using SLiM with a previous version of EnSight, you do not need to run SLiM from the CEI install directory. However, you are strongly encouraged to do so at this time to take advantage of any updates made to SLiM. At some point you will be required to run SLiM from the CEI install directory. In either case, do not try to run a previous slimd and a new slimd at the same time. The `install_unix` script will try to detect your current slim7.key from a previous installation of EnSight and, if it can, it will try to copy it into `${CEI_HOME}/license`. Should it not be able to, you will have to do this manually.
## 1.2 Troubleshooting the Installation

<table>
<thead>
<tr>
<th>Problem</th>
<th>Probable Causes</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>CD-ROM does not mount or read</td>
<td>CD not properly seated in the drive</td>
<td>Check that CD is properly seated.</td>
</tr>
<tr>
<td></td>
<td>System problem</td>
<td>Consult your local system administrator.</td>
</tr>
</tbody>
</table>
| EnSight’s Simple License Manager daemon does not start      | Several potential causes | Check the Simple License Manager log file ($CEI_HOME/license/slimd-log-
|                                                              |                          | HOST.txt) for error messages and correct as necessary.                   |
|                                                              |                          | Review: $CEI_HOME/license/README.TXT                                     |
|                                                              |                          | Check system log file.                                                   |
|                                                              |                          | Search on “slim” or “license” on our website FAQ’s:                     |
|                                                              |                          | www.ensight.com/FAQ/license_index.html                                   |
1.3 Verifying the Installation

Verifying installation is simple: the EnSight Client is started and the EnSight Server is connected to it. In the instructions that follow, \texttt{CLIENT\_HOST} refers to the system on which the EnSight Client was installed and \texttt{SERVER\_HOST} refers to the system on which the EnSight Server was installed. If the installation is stand-alone, then \texttt{CLIENT\_HOST} and \texttt{SERVER\_HOST} actually refer to the same system.

The instructions also assume that the environment variable \texttt{CEI\_HOME}, as well as the command search path have been set up correctly as described in the preceding section.

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (\textit{i.e.} the Client and Server are both running on the same workstation), EnSight will automatically start and connect the Client and Server processes transparently.

You should be logged in to the console of the workstation on which the EnSight Client and Server have been installed. In a the shell window, start EnSight using the \texttt{ensight7} shell script:

\begin{verbatim}
% ensight7
\end{verbatim}

This shell script will automatically start the Client and the Server and make the connection. You can tell if the connection was successful by clicking the Info... button on the right of the desktop and seeing “Connection accepted” in the EnSight Message Window. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. “EnSight 7” or “EnSight 7 Gold” will appear in the upper right corner of the graphics screen to indicate the license being used. You can now close the EnSight Message Window and proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the Connection) before contacting CEI support.

Starting EnSight for Distributed Use

Starting the Client

1. Log on to the console of \texttt{CLIENT\_HOST} and open at least two shell windows. Since the EnSight user interface will open on the right side of your screen, place the two shell windows on the left side.

2. In one of the shell windows, start the EnSight Client:

\begin{verbatim}
% ensight7.client -cm
\end{verbatim}

The \texttt{-cm} option tells the Client to begin listening for a connection from the Server. The EnSight Client user interface should appear on your workstation screen.

Starting the Server

3. In a different shell window on your workstation, log on to \texttt{SERVER\_HOST}:

\begin{verbatim}
% telnet SERVER\_HOST
\end{verbatim}

4. In the same shell window as step 3, start the EnSight Server:

\begin{verbatim}
% ensight7.server -c CLIENT\_HOST
\end{verbatim}

The \texttt{-c CLIENT\_HOST} option tells the EnSight Server to connect to the EnSight Client listening on \texttt{CLIENT\_HOST}.
You can tell if the connection was successful by clicking the Info... button on the right of the desktop and seeing “Connection accepted” in the EnSight Message Window (see the image below). Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the Connection) before contacting CEI support.

The EnSight Client after a successful connection with the Server process. Note the licensing information in the lower left corner of the Graphics Window.
## 1.4 Troubleshooting the Connection

<table>
<thead>
<tr>
<th>Problem</th>
<th>Probable Causes</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>EnSight Client and/or Server fails to start.</td>
<td>Client and/or Server executables are not found in the user’s command search path. The environment variable <code>CEI_HOME</code> is not set correctly.</td>
<td>Set the appropriate path and environment variable on both <code>CLIENT_HOST</code> and <code>SERVER_HOST</code> as described in the previous section.</td>
</tr>
<tr>
<td>Client and Server start, but manual connection fails.</td>
<td>Incorrect <code>CLIENT_HOST</code> provided to the Server.</td>
<td>Double-check your Client’s host name: run the <code>hostname</code> command on the Client system. Use the resulting name when starting the Server: <code>ensight7.server -c CLIENT_HOST</code></td>
</tr>
<tr>
<td>Possible networking problem.</td>
<td></td>
<td>Be sure you can <code>telnet</code> from <code>CLIENT_HOST</code> to <code>SERVER_HOST</code>. If not, consult your local system administrator for assistance.</td>
</tr>
<tr>
<td>EnSight socket ports (1105 and 1106) are in use.</td>
<td></td>
<td>Quit the Client. Execute the <code>netstat</code> command: `your_path/netstat -a</td>
</tr>
<tr>
<td>Wrong license or license cannot be found</td>
<td>The <code>slim7.key</code> file is not properly installed in the <code>$CEI_HOME/license</code> directory</td>
<td>Make sure the license key(s) have been installed correctly and that all users have read permission for the file(s). Review: <code>$CEI_HOME/license/README.TXT</code></td>
</tr>
<tr>
<td>You have a floating license and SLiM (slimd) is not running</td>
<td></td>
<td>Start the slimd license manager.</td>
</tr>
<tr>
<td>Previous versions of EnSight start when I type <code>ensight7</code></td>
<td><code>CEI_HOME</code> is not set to installation location or your site uses custom bin scripts which are not correct.</td>
<td>Be sure <code>CEI_HOME</code> is set correctly, and that <code>CEI_HOME/bin</code> is in your path. If custom bin scripts used, fix them.</td>
</tr>
</tbody>
</table>
1.5 Where’s the Rest?

After installing EnSight, you should proceed to the Chapter 3, *EnSight Graphical User Interface* for an introduction to the user interface and details on how to interact with EnSight.
Where's the Rest?
2 Installation For Windows Systems

EnSight is a powerful software package for the postprocessing, visualization, and animation of complex datasets. One of the unique features of EnSight is its ability to run distributed, sharing the workload between a Server process (handling data I/O and all compute intensive functions) and a Client process (managing user-interface interaction and graphic rendering). The EnSight Client and Server can either run on the same computer system (stand-alone operation) or the Client can run on a workstation and the Server can run on a remote computer system (distributed operation).

**Important:** The EnSight client is designed to run on a user’s workstation. It is not designed to run on a remote machine due to its interaction with the windowing system and graphics hardware. If it is run on a remote machine, performance will suffer and errors may occur.

If you are installing EnSight for a trial evaluation, you will be provided with a license key file which permits you to install and execute EnSight in either stand-alone or distributed mode on any computer system at your site for a limited amount of time.

If you have purchased or are leasing a license for EnSight, have chosen to run distributed, and always intend to run the Client processes on the same workstation(s), the easiest method of installation will be to node-lock the Clients to that (those) workstation(s). If, however, you anticipate running the Client process from a number of different workstations at different times, (the maximum number of concurrent EnSight processes is governed by the number of seats for which you are licensed) then you will need to install the EnSight License Manager.

### What You’ll Need For Installation

To install and run EnSight, you will need:

1. The EnSight 7 CD.
2. A PC workstation capable of running the EnSight software. The system should conform to the following:
   * OS must be Windows 2000, or Windows XP.
   * A Network Interface Card
   * Microsoft TCP/IP installed
   * A video board providing hardware accelerated OpenGL support is highly recommended. For a list of boards that have been tested by CEI and their respective performance, see the README.performance file located in the performance folder.
   * A minimum of 64MB of memory. 128 MB or more is recommended.
   * 300MHz or faster CPU is recommended
   * A screen resolution of at least 1024 by 768 is recommended.
3. Sufficient disk space. Full installation will require 180 MB of disk space.
4. A valid EnSight license key. If the key information was not included with your materials, it will be sent via FAX or email.
Contacting CEI

Should you encounter problems in your installation or use of EnSight, please contact CEI support:

Email: support@ensight.com
Hotline: 800-551-4448 (U.S)
         919-363-0883 (Non-U.S.)
Fax:    919-363-0833
2.1 Installation

The installation instructions are divided into the following three sections:

- Installation Procedure
- Post installation instructions
- Installing the EnSight license key

**Installation Procedure**

In order to install the EnSight software you will need to be logged in as administrator, or have administrator privileges.

To install the EnSight software:

1. Place the EnSight CD in your CD-ROM drive.
2. Open Windows Explorer.
3. Double click on Setup.exe in the top directory of the CD.
4. Follow the instructions as prompted by the setup program.

Once the installation is complete, the Windows machine must be rebooted in order for EnSight environment variables to take effect.

**Post Installation Instructions**

Acrobat .pdf files for local printing of all EnSight 7 documentation were installed in the INSTALL_DIR\CEI\ensight76\doc\Manuals directory during installation (see *Printing the documentation* on page 4-21 for more information).

The EnSight installation procedure sets the necessary environment variables for executing the EnSight software. However, if you wish to inspect these variables, do the following:

1. If Windows 2000:
   Start > Settings > Control Panel > System > Advanced > Environment Variables
   If Windows XP:
   Start > Control Panel > System > Advanced > Environment Variables

2. Check that the following is defined:

   **CEI_HOME** - should contain the path of the CEI directory where you installed the EnSight software. This will typically be:
   “C:\Program Files\CEI\”.

   **PATH** - should have appended to it the EnSight client and server directory paths. This will typically be:
   “C:\Program Files\CEI\EnSight76\machines\win32”
Installing the EnSight License Keys

You should have received an EnSight license key file from your EnSight representative. (If not, please contact CEI or your local distributor of EnSight). The following provides a brief overview of the EnSight keying mechanism. The information in the Overview provided is not critical to the installation process: you can skip it or return to it later if desired.

Keying Overview

The EnSight Client software can be installed either node-locked or floating. The choice for your installation was made when you purchased EnSight or requested a trial evaluation.

In a node-locked EnSight Client installation, the systemID numbers for all EnSight Client systems were provided to CEI. The Client process will read the license key file (slim7.key) to determine if it is running on a licensed host. The key file also contains information on the licensing company and expiration date.

Note: If you are installing for a trial evaluation, you will normally be installing EnSight as node-locked. Trial installations will use a key file which allows node-locked operation on any computer system at your site for a limited time.

The advantage of a node-locked EnSight Client installation is that it is simple to install – only the slim7.key file is required. The disadvantage is that you will only be permitted to run the EnSight Client on those workstations for which you have submitted systemID numbers.

If you have purchased or are leasing an EnSight license, you have the additional option of a floating EnSight Client installation in which the Client reads the slim7.key file as before. However, the file now contains information concerning which IP networks are valid for the license. In addition, the number of permitted seats (concurrent executions) is tracked using the EnSight’s Simple License Manager (or SLiM). The advantage of a floating EnSight Client installation is that EnSight can be executed from any workstation within the given IP network as long as the maximum seat count has not been exceeded. The disadvantage is that a system daemon must be installed and run in order to track the seat count.

Key Installation

The contents of the slim7.key file are provided by your EnSight representative.

Note: All machines which will execute the EnSight Client must have access to the key file. The Client process will always look for the file in the %CEI_HOME%\license directory.

1. Create the slim7.key file, which must be located in the %CEI_HOME%\license directory, by doing either a) or b):
   a. If you received your key contents via email, use a text editor (e.g. notepad) to create the file slim7.key, then copy into it the appropriate contents from the email, save the file, and exit the editor.
   b. If you did not receive the key contents by email, you will have to type them from the printed information you have received. Using a text editor (e.g. notepad), create the file slim7.key. Enter the text exactly as shown – in particular be careful with uppercase O and zero (0). Save the file and exit the text editor.
If you are installing a node-locked license, your installation is complete. You should now proceed to Verifying the Installation on page 2-8. If you encountered problems, please consult Troubleshooting the Installation on page 2-7 before contacting CEI support.

If you are installing EnSight’s Simple License Manager, continue. A designated host system will act as your license manager server and is referred to here as LM_HOST. The slim7.key file contains a slimd line that describes LM_HOST (the third word on the line is the name of the system). Most installations will run a single copy of the EnSight License Manager and will therefore have only one slimd line. However, it is possible to run multiple (redundant) license managers. If this was requested, your slim7.key file will have a slimd line for each host. Execute the following steps for each host, replacing LM_HOST as appropriate.

2. Log on to LM_HOST.

3. Create the file slim7.key, which must be located in the %CEI_HOME%\license directory, by doing either a) or b):
   a. If you received your key contents via email, use a text editor (e.g. notepad) to create the file slim7.key, then copy into it the appropriate contents from the email, save the file, and exit the editor.
   b. If you did not receive the key contents by email, you will have to type them from the printed information you have received. Using a text editor (e.g. notepad), create the file slim7.key. Enter the text exactly as shown – in particular be careful with uppercase O and zero (0). Save the file and exit the text editor.

If your system is running Microsoft Windows 2000, or Windows XP you can optionally install the License Manager (slimd_service.exe) as a system service. Under Windows 2000 or XP you can also install or uninstall the EnSight License Manager service at any time by running the program slimnstl.exe, which is found in the %CEI_HOME%\license\machines\win32 directory. It can also be installed as a service from the setup.exe program at the time EnSight is installed.

If the EnSight License Manager was installed as a Windows service (slimd_service), it will attempt to start automatically each time you boot your system. It will not be able to start until you have placed a valid key file (slim7.key) in the license directory, however. To check on its status, or to start it manually after creating your key file, for Windows 2000 go to Start > Settings > Control Panel > Administrative Tools (or for Windows XP go to Start > Control Panel > Administrative Tools) and open the Services dialog. The slimd_service should appear in the list of services. If it is running, its status should be listed as “started”. You can also start it manually by selecting it and clicking the dialog’s “Start” button.

You can also check the License Manager’s status by double-clicking on slimd_status.exe in the %CEI_HOME%\license\machines\win32 directory. This program will contact the license manager and display a status message.

If the slimd_service fails to start automatically when your system comes up, check the system and/or application error logs (using the Event Viewer) for possible error messages. You should also check the slimd log (%CEI_HOME\license\slimd-log-HOST.txt). Note that the CEI_HOME environment variable must be set for your system to run the license manager, even if you did not install the EnSight client or server.
The EnSight License Manager service will listen for connections on the socket port number given at the end of the applicable `slimd` line of the `slim7.key` file. If you did not specify a desired port number when you requested your key, port number 7790 is used. If this number conflicts with other usage at your site, you CANNOT change the key file – contact CEI for a new key.

This completes the installation process. You should now proceed to *Verifying the Installation* on page 2-8. If you encountered problems, please consult *Troubleshooting the Installation* on page 2-7 before contacting CEI support.
## 2.2 Troubleshooting the Installation

<table>
<thead>
<tr>
<th>Problem</th>
<th>Probable Causes</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>CD-ROM does not mount or read</td>
<td>CD not properly seated in the drive</td>
<td>Check that CD is properly seated.</td>
</tr>
<tr>
<td>System problem</td>
<td></td>
<td>Consult your local system administrator.</td>
</tr>
<tr>
<td>EnSight’s Simple License Manager daemon does not start</td>
<td>CEI_HOME not defined or incorrect</td>
<td>Set CEI_HOME environment variable.</td>
</tr>
<tr>
<td>Key file not valid</td>
<td></td>
<td>Inspect the slim7.key file for blank lines or extra characters at end of lines</td>
</tr>
<tr>
<td>slimd_service not installed as windows service.</td>
<td></td>
<td>Make sure slimd_service.exe is present in %CEI_HOME%\license\machines\win32 directory, run slimnstl.exe</td>
</tr>
<tr>
<td>slimd_service service not started</td>
<td></td>
<td>Start manually or see system and/or application error logs for autostart failure cause.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Check the slimd-log-HOST.txt log.</td>
</tr>
</tbody>
</table>

**Review:** %CEI_HOME%\license\README.TXT

Search on “slim” or “license” on our website FAQ’s:

www.ensight.com/FAQ/license_index.html
2.3 Verifying the Installation

Verifying installation is simple: the EnSight Client is started and the EnSight Server is connected to it. In the instructions that follow, \texttt{CLIENT\_HOST} refers to the system on which the EnSight Client was installed and \texttt{SERVER\_HOST} refers to the system on which the EnSight Server was installed. If the installation is stand-alone, then \texttt{CLIENT\_HOST} and \texttt{SERVER\_HOST} actually refer to the same system.

The instructions also assume that the environment variables \texttt{CEI\_HOME} and \texttt{PATH} have been set up correctly as described in the preceding section.

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (\textit{i.e.} the Client and Server are both running on the same workstation), you will perform an auto-connect of the EnSight Client and Server processes.

Choose EnSight7 from the Start menu > Programs toolbar.

This will automatically start the Client and the Server and automatically make the connection. If the connection is successful, you should see “Connection accepted” in the Status History area (just below the upper right corner of the EnSight window). Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the Connection) before contacting CEI support.

Starting EnSight for Distributed Use

Starting the Client

1. Log on to the \texttt{CLIENT\_HOST}. Double click the ens7cl.exe icon located in the \\
\texttt{INSTALL\_DIRECTORY\machines\win32} folder.
2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.
4. Click the “Connect Server” button.

Starting the Server

5. If the \texttt{SERVER\_HOST} is a UNIX machine, follow the “Starting the Server” instructions in Chapter 1. If the \texttt{SERVER\_HOST} is a Windows machine, continue with these instructions.

Log on to the \texttt{SERVER\_HOST}. Double click (or run, if you telnet to the machine) the ens7sv.exe icon located in the \\
\texttt{INSTALL\_DIRECTORY\machines\win32} folder.

6. In the resulting application console window, enter the name of the \texttt{CLIENT\_HOST} machine.

If the connection is successful, you should see “Connection accepted” in the Status History area (see the image on the next page). Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now proceed to Chapter 3.

If the connection failed, please consult the next section (Troubleshooting the Connection) before contacting CEI support.
The EnSight Client after a successful connection with the Server process. Note the licensing information in the lower left corner of the Graphics Window. (Unix image, Windows is similar)
## 2.4 Troubleshooting the Connection

<table>
<thead>
<tr>
<th>Problem</th>
<th>Probable Causes</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>EnSight Client and/or Server fails to start.</td>
<td>Client and/or Server executables are not found in the user’s command search path. The environment variable(s) CEI_HOME or PATH are not set correctly.</td>
<td>Set the appropriate path and environment variable on both CLIENT_HOST and SERVER_HOST as described in the previous section. (Do a restart of the computer after the installation)</td>
</tr>
<tr>
<td>Client and Server start, but manual connection fails.</td>
<td>Incorrect CLIENT_HOST provided to the Server.</td>
<td>Double-check your Client’s host name: use the hostname shown in the CLIENT_HOST application console, resulting from starting the EnSight client.</td>
</tr>
<tr>
<td>Wrong license or license cannot be found</td>
<td>The slim7.key file is not properly installed in the %CEI_HOME%\license directory.</td>
<td>Make sure the license key(s) have been installed correctly and that all users have read permission for the file(s).</td>
</tr>
<tr>
<td>Possible networking problem.</td>
<td></td>
<td>Be sure you can telnet from CLIENT_HOST to SERVER_HOST. If not, consult your local system administrator for assistance.</td>
</tr>
</tbody>
</table>
2.5 Where’s the Rest?

After installing EnSight, you should proceed to the next chapter, *EnSight Graphical User Interface* for an introduction to the user interface and details on how to interact with EnSight.
Where's the Rest?
3 EnSight Graphical User Interface

This chapter provides a quick introduction to the EnSight Graphical User Interface. In this chapter you will explore the layout of the user interface. Conventions used in the interface (such as how to select multiple items in a list) will also be discussed.
3.1 Tour of the GUI

The major components of the EnSight user interface are shown below.

**Main Menu**
The Main menu provides access to basic EnSight functionality. The Help menu (at the far right end of the menu bar) contains items for accessing online help.

**Message/Feedback Area**
The Message area displays brief messages during various operations. Note that Tool Tips are available for most icons.

**Information Button**
Clicking the Info... button will bring up the EnSight Message Window where additional information about EnSight operations is displayed. The color of the Info... button will indicate the type of the recent entries. Green indicates normal information, yellow indicates warnings, and red indicates errors.
Main Parts List

The Main Parts List displays all parts associated with the current session. A part is a named collection of elements (or cells) and associated nodes. All components of a part share the same set of attributes (such as color or line width).

Parts are accessed via the Main Parts list. Items in the list are selected by placing the mouse pointer over the item and clicking the left mouse button. You can extend a selection by pressing the shift key as you click an item. Additional techniques for selecting parts are discussed on page 3-10.

Understanding part concepts is crucial for productive use of EnSight. See section 4.5 Parts and Part Attributes for more information on parts. Also see Introduction to Part Creation in the online documentation.

Feature Icon Bar

The Feature Icon Bar contains icons associated with the major “features” of EnSight. Clicking the left mouse button on an icon selects the feature and opens the associated interface in the Quick Interaction area. Features include the following:

- **Color**
  Set the color of the parts selected in the Main Parts list. Parts can be colored either by a constant color or based on the value of a variable.

- **Contour**
  Create or modify a new contour (isoline) part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list.

- **Isosurface**
  Create or modify a new isosurface part using the part(s) selected in the Main Parts list as parents and based on an isovalue of the variable selected in the Variables list.

- **Particle Trace**
  Create or modify a new particle trace part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list as the velocity variable.

- **Clip**
  Create or modify a new clip part using the part(s) selected in the Main Parts list as parents. EnSight can create several types of clips including 1D line clips, planar clips, and quadric clips.

- **Vector Arrows**
  Create or modify a new vector arrow part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list. Vector arrows display direction and magnitude of a vector variable.

- **Elevated Surface**
  Create or modify a new elevated surface part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list. An elevated surface is a surface projected away from another surface with scaling based on the value of a variable.

- **Subset Parts**
  Create or modify a new subset part from node and/or element label ranges of model parts.

- **Displacement**
  Provides controls (in the Quick Interaction area) for specifying displacements.

- **Query/Plot**
  Provides controls for performing various query and plotting operations.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interactive Query</td>
<td>Provides controls for specifying interactive queries, which display variable values as the mouse is moved over objects in the Graphics Window, as the cursor tool is moved within a volume, or at specific node, element, ijk, or xyz locations.</td>
</tr>
<tr>
<td>Solution Time</td>
<td>Provides controls for managing time for transient datasets.</td>
</tr>
<tr>
<td>Flipbook Animation</td>
<td>Provides controls for specifying Flipbook animations. Flipbook animations are on-screen animations that permit graphic transformations during playback. Flipbooks can be used to animate clipping planes and isosurfaces and are also useful for visualizing transient data.</td>
</tr>
<tr>
<td>Keyframe Animation</td>
<td>Provides controls for specifying keyframe animations. Keyframe animation provides sophisticated motion control and output options for generating animations for either online presentation (e.g. MPEG) or video.</td>
</tr>
<tr>
<td>Variable Calculator</td>
<td>Opens the variable calculator, for creating computed variables.</td>
</tr>
<tr>
<td>Profile Plot</td>
<td>Create or modify a new profile plot part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list. A profile plot is the 1D counterpart of an elevated surface.</td>
</tr>
<tr>
<td>Developed Surface</td>
<td>Create or modify a new developed surface part using the part(s) selected in the Main Parts list as parents. A developed surface is constructed by unrolling a quadric clip about its axis of revolution.</td>
</tr>
<tr>
<td>Tensor Glyph</td>
<td>Create or modify a tensor glyph part using the part(s) selected in the Main Parts list (as parents) and the tensor selected in the Variables list.</td>
</tr>
<tr>
<td>Material Part</td>
<td>Create or modify parts which are based on the intersection or domain of material values.</td>
</tr>
<tr>
<td>Vortex Cores</td>
<td>Create or modify a vortex core part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list.</td>
</tr>
<tr>
<td>Shock Surfaces/Regions</td>
<td>Create or modify a shock surface or region part using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list.</td>
</tr>
<tr>
<td>Separation/Attachment Lines</td>
<td>Create or modify separation or attachment line parts using the part(s) selected in the Main Parts list as parents and the variable selected in the Variables list.</td>
</tr>
<tr>
<td>Boundary Layer Variables</td>
<td>Create or modify boundary layer variables.</td>
</tr>
</tbody>
</table>
Tour of the GUI

Quick Interaction Area

The Quick Interaction area provides the interface controls associated with the current feature selected from the Feature Icon bar. Changes in this area typically affect the parts currently selected in the Main Parts list. For example, if the currently selected feature (selected from the Feature Icon bar) is Color, the Quick Interaction area provides controls for setting the color of the parts currently selected in the Main Parts list. If the feature is Isosurface, the Quick Interaction area provides (among other things) a numeric type-in for setting the isovalue.

Warning: If you change a text field (for example, a numeric type-in), you must press return to have the change take effect! This applies not only to text fields in the Quick Interaction area, but throughout the EnSight user interface.

Many of the Quick Interaction areas – those associated with created parts – provide “Create” buttons. Clicking the Create button will build a new part (such as an isosurface or a clipping plane) based on current settings. Once built, the new part appears in the Main Parts list.

Some Quick Interaction areas will show a Variables list. Only variables appropriate for the selected feature will be shown in the list. A variable must be selected before the “Create” button is pressed.

Mode Selection Area

The Mode Selection Area selects the current major mode. Each mode has an associated set of icons that are loaded into the vertical Mode Icon bar when the mode is active. The six modes of EnSight are:

- **Part**
  - Part Mode icons control various part attributes. The operation of Part Mode icons applies only to the parts currently selected in the Main Parts list.

- **Annotation**
  - Annotation Mode provides control over various annotation entities: text, lines/arrows, color legends, and bitmap logos.

- **Plot**
  - Plot Mode provides control over the appearance and behavior of plot entities. A plot entity (typically created by a query operation) contains information for one or more X-Y plots. Plot entities can be positioned arbitrarily within the Graphics Window.

- **Viewport**
  - Viewport Mode provides control over viewports. The Graphics Window can be overlaid with multiple user-defined viewports. Viewports can be sized and positioned arbitrarily and have different backgrounds and borders.

- **Frame**
  - Frame Mode provides control over frames. A frame is a coordinate frame of reference that can be positioned independent of other frames. Parts can be attached to different frames permitting sophisticated and complex animations (e.g. exploding views). Note: By default, this mode is not visible. See Main Menu > Edit > Preferences... General User Interface - Frame Mode Allowed.
Tour of the GUI

Mode Icon Bar

The Mode Icon Bar displays the icons associated with the currently selected mode. The icons are arranged in a vertical scrolling region to the left of the Graphics Window. The Quick Icon Reference in the online documentation provides a quick reference for all EnSight icons as well as hotlinks from the icons to relevant online articles.

Transformation Control Area

The Transformation Control Area provides icons that control various aspects of object transformations. Transformations are accomplished by selecting the action (such as rotate), moving the mouse into the Graphics Window, clicking and holding the left mouse button, and dragging the mouse to achieve the desired transformation.

The Transformation Editor (opened by clicking the Transf Edit... icon) provides precise control over all types of transformations.

The possible actions are:

**Rotate**

Rotate: click and drag
- left-right to rotate about the vertical axis
- up-down to rotate about the horizontal axis
- left-right with the control key pressed to rotate about the screen Z axis.

**Translate**

Translate: click and drag
- left-right to translate in the horizontal direction
- up-down to translate in the vertical direction
- left-right with the control key pressed to translate in Z.

**Zoom**

Zoom: click and drag
- up/right to zoom out or down/left to zoom in
- with control key pressed to pan

Zoom is implemented by moving the virtual camera.

**Band Zoom**

Rubber-band zoom: click and hold the left mouse button on one corner of the desired viewing region, drag to opposite corner. An outline of the region will appear as you drag. Release the mouse button to zoom to the outlined region.

**Reset Tools and Viewports**

Open the Reset Tools and Viewports dialog that permits easy resetting of all or some transformation operations.

**Transformation Editor**

Open the Transformation Editor dialog. From within this editor, all global transforms (including scaling where appropriate) as well as frame and tool transforms can be controlled. There is also control of the center of transform, look-at/look-from locations, and z-clipping.
### Look down axis

- X  -Y  -Z  X  Y  Z

Set the axis the viewer looks down.

### Store/Recall view

- Store  Recall

Allows the user to store the current view and recall it at a later time.

### Undo

- Undo

Allows the user to undo the last transformation.

### Tool Tips

- **Tool Tips**

Controls whether tool tips are displayed when the mouse is moved over icons.

### Graphics Window

All 3D objects, as well as annotation entities, are displayed in the Graphics Window. The Graphics Window can contain additional (up to fifteen) user-defined viewports as well as X-Y plots.
3.2 User Interface Conventions

The EnSight user interface uses standard menus, dialogs, buttons, and other interface components (for Unix the OSF/Motif toolkit is used). This section provides information on these components as well as instructions for interaction.

**Dialog Windows**

A dialog is a window that groups interface components based on function. Dialogs are typically opened by making selections from a menu or clicking an icon. Menu selections and icons that open dialogs always end with “...”. Most EnSight dialogs can be opened and closed independently. In order to optimize scarce workstation screen real estate, you should close dialogs that are not in use. The default position of each dialog was chosen to best use the space available. You can, however, move the dialogs using your window manager and then save the positions for subsequent sessions (select Save Size and Position of Main Windows from the Edit > Preferences... General User Interface dialog).

Dialogs typically consist of buttons, menus, lists, and areas to type in. Some EnSight dialogs also have expandable sections that let you hide parts of the interface that you use infrequently. Each expandable section consists of an indicator button, a section title, and the contents of the section. The indicator button and the section title are always visible. If the section is open, the contents are visible as well.

The indicator button is a toggle switch for opening and closing the section. For Unix, a right-pointing arrow indicates a closed section. Clicking the arrow will open the section. A down pointing arrow indicates an open section. Clicking the arrow will close the section. These indicators are referred to as turndown buttons.

(Note: For Windows, a regular toggle button is used.)

[Diagram of EnSight user interface with dialog windows highlighted]
**Menus**

The EnSight documentation uses the following terms to describe various types of menus:

- **Menu bar**: A horizontal strip across the top of a dialog listing menu titles.

- **Pull-down menu**: A pull-down menu is one accessed directly from a menu bar.

- **Cascade menu or submenu**: A submenu is accessed from another menu selection. Submenu selections are indicated by a right-pointing arrow.

- **Options menu or pop-up menu**: An options menu is accessed by pressing the associated button. The current selection always appears as the button title.

---

Windows Version will not have the diamond buttons, but selection will work as described for diamond buttons.
Lists (such as the Main Parts list) are presented in dialogs as scrollable sections. Various mechanisms are used to select items from a list for further action:

<table>
<thead>
<tr>
<th>To...</th>
<th>Do This...</th>
<th>Details...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an item</td>
<td>Single-click</td>
<td>Place the mouse pointer over the item and click the left mouse button. The item is highlighted to reflect the “selected” state.</td>
</tr>
<tr>
<td>Extend a contiguous selection</td>
<td>Select-drag</td>
<td>Place the mouse pointer over the first item. Click and hold the left mouse button as you drag over the remaining items to be selected. Only contiguous items may be selected in this fashion.</td>
</tr>
<tr>
<td>Extend a (possibly long) contiguous selection</td>
<td>Shift-click</td>
<td>Place the mouse pointer over the item. Press the shift key and click the left mouse button. This action will extend a selection to include all those items sequentially listed between the previous selection and this one.</td>
</tr>
<tr>
<td>Extend a non-contiguous selection</td>
<td>Control-click</td>
<td>Place the mouse pointer over the item. Press the control key and click the left mouse button. This action will extend a selection by adding the new item, but not those in-between any previously selected items.</td>
</tr>
<tr>
<td>De-select an item</td>
<td>Control-click</td>
<td>Place the mouse pointer over the selected item. Press the control key and click the left mouse button. This action will de-select the item.</td>
</tr>
</tbody>
</table>

You can also double-click list items. The result depends on the list and type of item. For model parts in the Main Parts list, a double-click will open the Color Quick Interaction area. For created parts, the Quick Interaction area for the corresponding part type will open. Double-clicking variables in the Main Variables list will open the Feature Detail Editor for Variables with the clicked variable already selected. To double-click, place the mouse pointer over the item and click the left mouse button twice in rapid succession.
**Buttons**

EnSight uses the following kinds of buttons:

**Rectangular**  
Place the mouse cursor in the button area and click the left mouse button. Rectangular buttons typically access the function described in the label. If the label is followed by “...” then the button opens another dialog.

**Arrow**  
Place the mouse cursor in the button area and click the left mouse button. Arrow buttons typically have an associated text field or scroll bar. Clicking the button increments or decrements the text field or scroll bar value.

**Diamond**  
Place the mouse cursor in the button area and click the left mouse button. Diamond buttons (also called radio buttons) are toggles that select an item from a mutually exclusive list. Exactly one diamond button of a group can be on at any given time. Note that for the Windows Version no diamond buttons are used, but that the selection of items works as described here.

**Square**  
Place the mouse cursor in the button area and click the left mouse button. Square buttons are toggles that access the function indicated by the label.
Text Fields

EnSight utilizes two types of text fields:

**Information Text Fields**

These text fields are used to report information and cannot be edited by the user. Information text fields are surrounded with a single pixel border.

**Editable Text Fields**

Place the mouse cursor in the text field and click to insert a blinking insertion cursor. Several techniques are available to accelerate text editing. Select a single word by double-clicking or the entire string by triple-clicking. Selected text is replaced by subsequent typing. The left and right arrow keys (on most systems) will move the insertion cursor.

*Note: You must type return (while the blinking insertion cursor is still in the field) for changes to text fields to take effect!*

Where appropriate (*i.e.* in File Selection dialogs), EnSight recognizes the following shortcut specifications for UNIX directories:

```
~/ Expands to your home directory.
~username/ Expands to the home directory of username.
./ Expands to the current working directory.
../ Expands to the parent directory of the current working directory
```

(For Windows systems, one should use a `\` (backslash) in place of the `/` (forward slash)).

Note that standard wildcard characters (*e.g.* `*` to represent a series of zero or more arbitrary characters) can also be used in File Selection dialogs.
3.3 Where’s the Rest?

Once you are familiar with the EnSight user interface, proceed to the next chapter, *Simple Demonstration*.

Several online articles provide overview and reference information. See the *EnSight Overview* (Help > EnSight Overview...) and the *Quick Icon Reference* (Help > Quick Icon Reference...).

For additional overview information, see Chapter 1 of the User Manual. Chapter 5 of the User Manual also contains an overview of the user interface.

Finally, the table of contents and/or the index of the following, as well as internal links, are easily navigated. For questions related to a specific task, see the How To Manual (Help > How To Manual ...). For detailed information on a feature or concept, see the User Manual (Help > User Manual ...).
Where's the Rest?
4 Simple Demonstration

This chapter provides a step-by-step demonstration of basic EnSight operation. After successfully completing this chapter, you should be able to:

- start EnSight (including the Client-Server connection),
- read a dataset and load a model,
- transform objects in the Graphics Window: rotate, translate, and zoom,
- reset transformations,
- create and manipulate additional viewports,
- work with parts and change part attributes,
- access the online documentation,
- exit EnSight.
4.1 Starting EnSight

If you successfully performed the installation verification as described in Verifying the Installation on page 1-14, you have already started EnSight and connected the Client and Server. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type (stand-alone or distributed).

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (i.e. the Client and Server are both running on the same workstation), you can use these simplified steps to start EnSight and auto-connect the Client and Server processes.

For Unix Systems:

You should be logged into the console of the workstation on which the EnSight Client and Server have been installed. In addition, the CEI_HOME and other ENSIGHT7 environment variables, as well as your command search path must be set up correctly as described on page 1-8.

1. Change to the directory containing the simple frame dataset. (The dataset contained in this directory will be loaded into EnSight in section 4.2.)

   % cd $CEI_HOME/ensight76/data/frame

2. Start EnSight using the ensight7 shell script:

   % ensight7

For Windows Systems:

1. Choose EnSight7 from the Start > Programs > CEI menu.

   This will automatically start the Client and the Server and make the connection. If you click on the Info... button on the Desktop, you should see “Connection accepted” in the EnSight Message Window dialog. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now proceed to the next section.

   If the connection failed, please consult Troubleshooting the Connection on page 1-16 before contacting CEI support.

Starting EnSight for Distributed Use

If your installation of EnSight is distributed (i.e. the Client and Server are running on different computer systems), use the steps given below to start EnSight. Note that this operation is a manual connection. EnSight can be set up to perform the connection automatically. See Help > How To Manual ... and click on How To Connect Automatically for details.

In the instructions that follow, CLIENT_HOST refers to the system on which the EnSight Client was installed and SERVER_HOST refers to the system on which the EnSight Server was installed.
The instructions also assume that the `CEI_HOME` environment variable as well as the command search path have been set up correctly as described on page 1-8.

**For UNIX Systems:**

1. Log on to the console of `CLIENT_HOST` and open at least two shell windows. Since the EnSight user interface will open on the right side of your screen, place the two shell windows on the left side.
2. In the first shell window, start the EnSight Client:
   ```
   % ensight7.client -cm
   ```
   The `-cm` option tells the Client to begin listening for a connection from the Server. The EnSight Client user interface should appear on your workstation screen.
3. In the second shell window on your workstation, log on to `SERVER_HOST`:
   ```
   % telnet SERVER_HOST
   ```
4. In the second shell window, change to the directory containing the simple frame dataset. (The dataset contained in this directory will be loaded into EnSight in section 4.2.)
   ```
   % cd $CEI_HOME/ensight76/data/frame
   ```
5. In the second shell window, start the EnSight Server:
   ```
   % ensight7.server -c CLIENT_HOST
   ```
   The `-c CLIENT_HOST` option tells the EnSight Server to connect to the EnSight Client listening on `CLIENT_HOST`.

**For Windows Systems:**

1. Log on to the `CLIENT_HOST`. Double click the `ens7cl.exe` icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.
4. Click the “Connect Server” button.
5. If the `SERVER_HOST` is a UNIX machine, follow steps 3 through 5 in the “For UNIX Systems” above. If the `SERVER_HOST` is a Windows machine, continue with these instructions.

Log on to the `SERVER_HOST`. Double click (or run, if you telnet in to the machine) the `ens7sv.exe` icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
6. In the resulting application console window, enter the name of the `CLIENT_HOST` machine.

The Server should make the connection. If the connection is successful, you should see “Connection accepted” in the Status History area (just below the upper right corner of the EnSight window). Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window.

If the connection failed, please consult Troubleshooting the Connection on page 1-16.
before contacting CEI support.

**Distributed Use - Automatic Connection**

You can perform an *automatic connection* where the Server starts automatically and connects to the Client, even though the two processes are on different host systems. This type of connection requires some initial setup and is not discussed in the *Getting Started* manual. However, once configured, the automatic connection lets you start a session in a single step.

See *How To Connect Automatically* (Help > How To Manual ...) in the online documentation for details.

(For information on the online help facility, see *Using Online Help* on page 4-20.)
4.2 Reading a Dataset

After starting EnSight, the next step in any session is to read a dataset and load the parts. To read a dataset, the relevant files and data format must be specified. EnSight supports several formats common in the computational analysis field. In addition, EnSight also supports native formats suitable for storing both block structured and unstructured (i.e. finite-element) geometry. In this example, we will load an EnSight native format file.

After you have successfully started EnSight (as detailed in the previous section), you are ready to read a dataset.

1. Select File > Data (Reader)... from the EnSight Main menu.

For EnSight to properly read data, it must know both the file name and format. In this example, we will load a simple geometry that requires only a single data file – the geometry file. Many datasets require the specification of at least one other file that contains results (variable) information.

For UNIX: Since we initially started EnSight (in the previous section) from the desired directory ($CEI_HOME/ensight76/data/frame), this directory is opened automatically (as seen in the Directories list).

For Windows: You will be in the machines\win32 directory. You need to go up two levels by twice double clicking on the .. directory, then go down to data, then the frame directory.

2. Click frame.case in the Files list.

3. Be sure the Format is set to Case (it is by default).

4. Click (Set) Case to set the casefile to the file currently selected in the Files list (i.e. frame.case).

5. Click Okay to accept the selections and close the dialog window.

See Help > How To Manual ... (and select How To Read Data) for more information on data reading. In this case, you can also get there by clicking the Help button.
When the File Selection dialog is closed, EnSight reads the file and opens the Data Part Loader dialog. During the initial read, EnSight determines the individual parts available in the file. You can choose to load all the parts, or only a subset. You can also pick an initial visual representation for each part individually (more on this later).

6. Click Load All. This will load the parts into EnSight and display them in the Main Parts list.

7. Click Close.

The four constituent parts are now listed in the Main Parts list and displayed in the Graphics Window:

Note: To improve the legibility of the Getting Started manual, all images of the Graphics Window are shown with a white background rather than the default black background that EnSight uses.

See How To Read EnSight 7 Data (Help > How To Manual ...) for more information on the Data Part Loader dialog. There is a How To Read <format> Data for each direct, built-in reader format.
Getting Your Data Into EnSight

EnSight supports a number of common data formats as well as interfaces to various simulation packages. There are four different means to get your data into EnSight.

**Type 1 - Direct (built-in) Readers** - Are accessed by choosing the desired format in the Data Reader dialog. These include common data formats as well as a number of readers for commercial software. See *How To Read and Load Data* (Help > How To Manual ...).

**Type 2 - User-Defined readers** - A library of routines is provided with EnSight to allow users to create their own custom interfaces. Like Type 1, User-Defined Readers have the advantage of not requiring a separate data translation step and thus reduce user effort and disk storage requirements. A number of User-Defined Readers are provided with EnSight; complete documentation and dummy routines may be found in the directory `$CEI_HOME/ensight76/src/readers`.

**Type 3 - Stand - Alone Translators** - May be written by the user to convert data into EnSight format files. A complete description of EnSight formats may be found in Chapter 11 of the EnSight Online User Manual. The suggested format to use is the “EnSight Case Gold” format. Several translators are provided with EnSight. These are found in the directory `$CEI_HOME/ensight76/translators`. Translators must first be compiled before they may be used. Some require links to libraries provided by the vendor of the program in question. See the README files found in each translator’s directory.

**Type 4 - EnSight Formats** - A growing number of software suppliers support the EnSight formats directly, i.e. an option is provided in their products to output data in one of the EnSight formats.

The table that follows summarizes all of the data formats and software packages for which an interface of Type 1-4 exists. As this information changes frequently, please consult our website (www.ensight.com/products/solvers.html) or your EnSight support representative should you have any questions. If your format or program is not listed here, there is the possibility that an interface does indeed exist. Contact EnSight support for assistance. Should you create a User-Defined Reader or Stand - Alone Translator and wish to allow its distribution with EnSight, please send an email to this effect to support@ensight.com.

<table>
<thead>
<tr>
<th>Data Format / Program</th>
<th>Type</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABAQUS</td>
<td>1</td>
<td>Direct reader for binary or ascii (.fil) files (ABAQUS STANDARD or EXPLICIT)</td>
</tr>
<tr>
<td>ACUSOLVE</td>
<td>2</td>
<td>Contact vendor for information</td>
</tr>
<tr>
<td>ADAGIO</td>
<td>2</td>
<td>Use Exodus II reader</td>
</tr>
<tr>
<td>ADINA</td>
<td>3</td>
<td>Use I-DEAS neutral files and translators</td>
</tr>
<tr>
<td>ALEGRA</td>
<td>2</td>
<td>Use Exodus II reader</td>
</tr>
<tr>
<td>ANSYS</td>
<td>1</td>
<td>Direct reader for binary .rst, .rth, .rmq, .rl files</td>
</tr>
<tr>
<td>CASE (EnSight6/EnSight Gold)</td>
<td>1</td>
<td>Native EnSight formats, EnSight6 Case and EnSight Gold Case</td>
</tr>
<tr>
<td>CFD++</td>
<td>4</td>
<td>Exports EnSight Case format</td>
</tr>
<tr>
<td>CFD-ACE</td>
<td>2</td>
<td>Contact vendor for DTF reader</td>
</tr>
<tr>
<td>CFD-FASTRAN</td>
<td>2</td>
<td>Contact vendor for DTF reader</td>
</tr>
<tr>
<td>CFDESIGN</td>
<td>2</td>
<td>Uses Tecplot files and reader</td>
</tr>
<tr>
<td>CFF</td>
<td>2</td>
<td>User reader for Common File Format from BOEING (WIND code)</td>
</tr>
<tr>
<td>CFX4</td>
<td>2, 3</td>
<td>User reader, and translator (useful if results contain massed particles)</td>
</tr>
<tr>
<td>CFX5</td>
<td>4</td>
<td>Code exports EnSight Case format</td>
</tr>
<tr>
<td>CFX-TASCflow</td>
<td>3</td>
<td>Converts TASCflow output to EnSight format (or use PLOT3D converter from vendor)</td>
</tr>
<tr>
<td>CGNS</td>
<td>3</td>
<td>User reader</td>
</tr>
<tr>
<td>COBALT</td>
<td>2, 4</td>
<td>User reader (obtain from vendor) - or - Exports EnSight Case Gold format</td>
</tr>
<tr>
<td>CRAFT</td>
<td>4</td>
<td>Exports EnSight Case Gold format</td>
</tr>
<tr>
<td>CRUNCH</td>
<td>4</td>
<td>Exports EnSight Case Gold format</td>
</tr>
<tr>
<td>Data Format / Program</td>
<td>Type</td>
<td>Comments</td>
</tr>
<tr>
<td>----------------------</td>
<td>------</td>
<td>----------</td>
</tr>
<tr>
<td>CTH</td>
<td>2</td>
<td>Use Exodus II reader</td>
</tr>
<tr>
<td>ECLIPSE</td>
<td>3</td>
<td>Contact CEI for details</td>
</tr>
<tr>
<td>ENSIGHT (EnSight 5)</td>
<td>1</td>
<td>Original EnSight format (unstructured)</td>
</tr>
<tr>
<td>ESTET</td>
<td>1</td>
<td>Direct reader</td>
</tr>
<tr>
<td>EXODUS II</td>
<td>2</td>
<td>User reader</td>
</tr>
<tr>
<td>FAST Unstructured</td>
<td>1</td>
<td>Direct reader for NASA FAST unstructured format</td>
</tr>
<tr>
<td>FEFLO</td>
<td>3</td>
<td>Contact vendor for information</td>
</tr>
<tr>
<td>FEMWATER</td>
<td>2</td>
<td>Use GMS reader</td>
</tr>
<tr>
<td>FENSAP</td>
<td>4</td>
<td>Contact vendor for information</td>
</tr>
<tr>
<td>FIDAP</td>
<td>1</td>
<td>Direct reader for FIDAP neutral (FDNEUT) files</td>
</tr>
<tr>
<td>FINE/Aero</td>
<td>1, 2</td>
<td>Use PLOT3D or CGNS files/reader</td>
</tr>
<tr>
<td>FINE/Turbo</td>
<td>1, 2</td>
<td>Use PLOT3D or CGNS files/reader</td>
</tr>
<tr>
<td>FIRE</td>
<td>4</td>
<td>Code exports EnSight format</td>
</tr>
<tr>
<td>FLOW-3D</td>
<td>2</td>
<td>User reader for FLOW-3D results (flsgrf) files</td>
</tr>
<tr>
<td>FLUENT (particle files)</td>
<td>3</td>
<td>Converts Fluent particle file to EnSight format</td>
</tr>
<tr>
<td>FLUENT</td>
<td>4</td>
<td>Code exports EnSight Casefile format</td>
</tr>
<tr>
<td>FOAM</td>
<td>4</td>
<td>Contact developer (Imperial College) for interface details</td>
</tr>
<tr>
<td>GASP</td>
<td>4</td>
<td>Exports EnSight Case format</td>
</tr>
<tr>
<td>GMS</td>
<td>2</td>
<td>User reader for GMS groundwater modeling framework, contact CEI for information</td>
</tr>
<tr>
<td>GUST</td>
<td>4</td>
<td>Exports EnSight Case format</td>
</tr>
<tr>
<td>HDF</td>
<td>2</td>
<td>Contact CEI for information</td>
</tr>
<tr>
<td>I-DEAS</td>
<td>3</td>
<td>Translator for I-DEAS FEA neutral file</td>
</tr>
<tr>
<td>IO/API</td>
<td>2</td>
<td>User reader for MODELS 3 framework, contact CEI for information</td>
</tr>
<tr>
<td>KIVA</td>
<td>2, 3</td>
<td>Conversion routines to export EnSight format, contact CEI for info</td>
</tr>
<tr>
<td>LS-DYNA</td>
<td>2</td>
<td>User reader for d3plot files</td>
</tr>
<tr>
<td>MAYA ESC</td>
<td>4</td>
<td>Contact vendor for information</td>
</tr>
<tr>
<td>MODELS 3</td>
<td>2</td>
<td>Use IO/API reader</td>
</tr>
<tr>
<td>MOVIE.BYU</td>
<td>1</td>
<td>Direct reader for MOVIE.BYU format files</td>
</tr>
<tr>
<td>MPSGS 4.1</td>
<td>1</td>
<td>Direct reader for MPSGS, EnSight’s predecessor</td>
</tr>
<tr>
<td>MSC.DYTRAN</td>
<td>2</td>
<td>User reader for MSC/Dytran archive (.arc) or data (.dat) files</td>
</tr>
<tr>
<td>MSC.NASTRAN</td>
<td>2</td>
<td>User reader for binary OP2 files</td>
</tr>
<tr>
<td>MUSE/Prism</td>
<td>2</td>
<td>User reader from Thermoanalytics</td>
</tr>
<tr>
<td>NCC</td>
<td>2</td>
<td>User reader interface to National Combustion Code, contact CEI for info</td>
</tr>
<tr>
<td>N3S</td>
<td>1</td>
<td>Direct reader for the EDF code N3S</td>
</tr>
<tr>
<td>Net.CDF</td>
<td>2</td>
<td>User reader, contact CEI for information</td>
</tr>
<tr>
<td>NSMB</td>
<td>2</td>
<td>User reader developed by CERFACS and CSCS</td>
</tr>
<tr>
<td>NSU2D / NSU3D</td>
<td>4</td>
<td>Contact CEI for information</td>
</tr>
<tr>
<td>PATRAN</td>
<td>3</td>
<td>Converts PATRAN neutral files to MOVIE.BYU format</td>
</tr>
<tr>
<td>PHOENIX</td>
<td>3</td>
<td>Use PLOT3D file/reader, contact CEI for information</td>
</tr>
<tr>
<td>PLOT3D</td>
<td>3</td>
<td>Direct reader for PLOT3D and FAST structured formats</td>
</tr>
<tr>
<td>POLY-3D</td>
<td>3</td>
<td>Contact vendor for information</td>
</tr>
<tr>
<td>POLYFLOW</td>
<td>4</td>
<td>Outputs EnSight Case format</td>
</tr>
<tr>
<td>POWERFLOW</td>
<td>3</td>
<td>Contact CEI for information on interfaces available</td>
</tr>
<tr>
<td>PRESTO</td>
<td>2</td>
<td>Use Exodus II reader</td>
</tr>
<tr>
<td>PRONTO</td>
<td>2</td>
<td>Use Exodus II reader</td>
</tr>
<tr>
<td>PXI</td>
<td>2</td>
<td>User reader for Parallel Exodus Interface format</td>
</tr>
<tr>
<td>RADIOSS</td>
<td>3</td>
<td>Contact vendor for interface details</td>
</tr>
<tr>
<td>RADTHERM</td>
<td>2</td>
<td>User reader from Thermoanalytics</td>
</tr>
<tr>
<td>RESCUE</td>
<td>2</td>
<td>User reader for Schlumberger reservoir modeling framework, contact CEI for information</td>
</tr>
<tr>
<td>SCRUY</td>
<td>2</td>
<td>User reader</td>
</tr>
<tr>
<td>SILO</td>
<td>2, 3</td>
<td>Reads various formats supported by SILO API</td>
</tr>
<tr>
<td>SPHINX</td>
<td>4</td>
<td>Code exports EnSight format</td>
</tr>
<tr>
<td>STAR-CD (Version 3.0.5 &amp; up)</td>
<td>4</td>
<td>Code exports EnSight Casefile format (including particle data)</td>
</tr>
<tr>
<td>STL</td>
<td>2</td>
<td>User reader for STL geometry files (may also be exported)</td>
</tr>
<tr>
<td>TAHOE</td>
<td>4</td>
<td>Contact CEI for information on interfaces available</td>
</tr>
<tr>
<td>TECPLLOT</td>
<td>2</td>
<td>User reader for TECPLLOT structured and unstructured formats</td>
</tr>
<tr>
<td>Telluride</td>
<td>4</td>
<td>Code exports EnSight format</td>
</tr>
<tr>
<td>UNCLE</td>
<td>2</td>
<td>User reader, contact CEI for details</td>
</tr>
<tr>
<td>UNIC-CFD</td>
<td>3</td>
<td>Contact vendor for details</td>
</tr>
<tr>
<td>USM3D</td>
<td>4</td>
<td>Contact CEI for information</td>
</tr>
<tr>
<td>VECTIS</td>
<td>2, 3</td>
<td>User reader</td>
</tr>
</tbody>
</table>
### 4.3 Performing Transformations

It’s easy to rotate, translate, and zoom the geometry displayed in the Graphics Window.

**Note:** By default EnSight ships with the left mouse button defined to do Transformation Actions, the middle button defined to do Translations directly, and the right mouse button defined to do Zoom operations directly. The assignment of operations to mouse buttons can be customized by the user.

<table>
<thead>
<tr>
<th>Rotate using the mouse:</th>
<th>or:</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Move the mouse pointer into the Graphics Window.</td>
<td>2. Click and hold the <strong>left</strong> mouse button and drag the mouse left and right. The model rotates about the vertical (Y) axis.</td>
</tr>
<tr>
<td>3. Click and hold the <strong>left</strong> mouse button and drag the mouse left and right. The model rotates about the vertical (Y) axis.</td>
<td>4. Drag the mouse up and down. The model rotates about the horizontal (X) axis.</td>
</tr>
<tr>
<td>4. Drag the mouse up and down. The model rotates about the horizontal (X) axis.</td>
<td>5. Hold down the control key and move the mouse left and right. The model rotates about the Z axis.</td>
</tr>
<tr>
<td>5. Hold down the control key and move the mouse left and right. The model rotates about the Z axis.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Translate using the mouse:</th>
<th>or:</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Move the mouse pointer into the Graphics Window.</td>
<td>2. Click and hold the <strong>middle</strong> mouse button and drag the mouse left and right. The model translates horizontally.</td>
</tr>
<tr>
<td>3. Click and hold the <strong>left</strong> mouse button and drag the mouse left and right. The model translates horizontally.</td>
<td>3. Drag the mouse up and down. The model translates vertically.</td>
</tr>
<tr>
<td>4. Drag the mouse up and down. The model translates vertically.</td>
<td>4. Hold down the control key and move the mouse left and right. The model translates in and out along the Z axis.</td>
</tr>
<tr>
<td>5. Hold down the control key and move the mouse left and right. The model translates in and out along the Z axis.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Zoom using the mouse:</th>
<th>or:</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Move the mouse pointer into the Graphics Window.</td>
<td>2. Click and hold the <strong>right</strong> mouse button and drag the mouse up or to the right. The model zooms out.</td>
</tr>
<tr>
<td>3. Click and hold the <strong>left</strong> mouse button and drag the mouse up or to the right. The model zooms out.</td>
<td>3. Drag the mouse down or to the left. The model zooms in.</td>
</tr>
<tr>
<td>4. Drag the mouse down or to the left. The model zooms in.</td>
<td>4. Hold down the control key and move the mouse. The model pans.</td>
</tr>
<tr>
<td>5. Hold down the control key and move the mouse. The model pans.</td>
<td></td>
</tr>
</tbody>
</table>

Note that the zoom operation actually moves the virtual camera rather than moving the geometry.
Performing Transformations

See *How To Rotate, Zoom, Translate, Scale* (Help > How To Manual ...) for more information on model transformations.

At this point, you have probably transformed the model into a strange orientation. You can easily reset the view to the default position and orientation.

1. Click Reset... in the Transformation Control area. This opens the Reset Tools and Viewport(s) dialog.

You can use this dialog to clear the selected transform operator only (*i.e.* the one currently selected in the Transformation Control area), all rotate, translate, scale transforms (but not zoom), or to “reinitialize” the entire view. Reinitialize will not only clear all transformations, it will also reposition the virtual camera such that all currently visible parts are scaled to fit the Graphics Window, and make the center of rotation to be the centroid of the visible parts.

2. Click Reinitialize.

3. Click Close.

See *How To Reset Tools and Viewports* (Help > How To Manual ...) for more information on resetting transformations.
You can also perform precise transformations (such as rotating 22.5 degrees about the X axis) using the Transformation Editor.

4. Click Transf Edit... in the Transformation Control area. This opens the Transformation Editor dialog in Global Transform mode.

   In this mode, changes to the Transformation Editor apply only to the currently selected action in the Transformation Control area (e.g. rotate or translate).

5. Select Rotate icon in the Transformation Editor dialog.

6. Select X Axis.

7. Place the mouse pointer in the Increment field and double-click the left mouse button to select the entire value “1.000000”.

8. Enter the value “22.5” and press return.

The model is rotated precisely 22.5 degrees about the X axis.

9. Grab the slider (click and hold the left mouse button) and drag left and right. Note that the actual number of degrees rotated is printed above the slider thumb switch as it is moved.

Experiment with the Transformation Editor – set Axis to other values or change the current action in the Transformation Control area to edit translation or scale. (If the model doesn’t seem to move in the translate mode, increase the increment and limit, press return, and move the slider again.)

When you are done:

10. Click Close.

11. Reinitialize all transformations as described in steps 1-3 above.
EnSight makes use of certain keyboard keys to simplify common operations. A quick reference is shown below. Make sure the main EnSight window is selected, then try these function keys.

**F1** - Rotate 45 degrees about x-axis (hold Control key down for -45 degree rotations)
**F2** - Rotate 45 degrees about y-axis (hold Control key down for -45 degree rotations)
**F3** - Rotate 45 degrees about z-axis (hold Control key down for -45 degree rotations)
**F4** - Toggle on/off spin mode (Next rotate will continue to spin)
**F5** - Show standard right view (Look down the x-axis)
**F6** - Show standard top view (Look down the y-axis)
**F7** - Show standard front view (Look down the z-axis)
**F8** - Return scene to view prior to F5, F6, or F7
  (hold Control key down while pressing F5, F6, F7 will store current view to selected Fx key)
**F9** - Toggle on/off full screen mode
**F10** - Decrease stereo separation angle
**F11** - Increase stereo separation angle  (If hardware supports stereo)
**F12** - Toggle on/off stereo display
**P key** - Used for picking operations
**A key** - Abort keyframe animation
**Control key** - When held during rotates or translates, model rotates/translates about z-axis

For more information, see the online help “HowTo” sections (Help > How To Manual ...):

F10, F11, F12 - How To Enable Stereo Viewing.

The user may also assign EnSight commands or macros to any keyboard or mouse key. See How To Define and Use Macros (Help > How To Manual ...) for more information.
4.4 Creating and Manipulating Viewports

In addition to the default viewport (which takes up the entire Graphics Window and cannot be changed), EnSight provides up to fifteen additional user-defined viewports. These viewports can be sized and positioned arbitrarily and can have different border and background attributes. By default, each viewport displays all parts that are currently visible. You can, however, have viewports that display only a subset of the visible parts.

To create new viewports:

1. Click VPort in the Mode Selection area to enter Viewport mode.
2. Click the New Viewport icon to create a new viewport.
3. Click the New Viewport icon again to create another new viewport.

Your Graphics Window should look like the following. New viewports initially appear in columns starting from the top left corner. Note that the second viewport created has a light green border: this viewport is the currently selected viewport. Viewport operations (such as setting a border) operate only on the currently selected viewport(s). To select a viewport:

4. Move the mouse pointer into the Graphics Window and within the bounds of the first new viewport (the upper one with a white border).
5. Click the left mouse button to select the viewport.
You can easily resize or reposition a viewport. To reposition a viewport:

6. Place the mouse pointer within the bounds (but not too close to an edge) of the selected viewport. The mouse cursor should be an arrow.

7. Click and hold the left mouse button and drag the viewport to the desired location.

To resize a viewport:

8. Place the mouse pointer within the bounds of the selected viewport. Move the pointer towards one of the corners until the cursor changes to an arrow and right-angle.

9. Click and hold the left mouse button and drag the viewport corner to the desired location.

You can also move a single viewport edge by positioning the pointer over an edge, clicking, and dragging. Experiment with resizing and repositioning the viewports.

Viewport mode is exclusively for changing the properties of viewports. You cannot work with parts or rotate objects while in Viewport mode. To return to normal operation, change the mode from Viewport to Part.

10. Click Part in the Mode Selection area to enter Part mode.

11. Click Rotate in the Transformation Control area.

12. Move the mouse into the Graphics Window and into one of the new viewports you created. Note that the selected viewport is no longer highlighted with the light green border.

13. Click the left mouse button and drag to rotate the objects in the viewport. The other viewports are unchanged – each viewport maintains its own set of transformations.

User-defined viewports can easily be deleted when they are no longer required:

14. Click VPort in the Mode Selection area to enter Viewport mode.

15. Move the mouse pointer into the Graphics Window and within the bounds of one of the two viewports you created. Click to select the viewport.

16. Click the Delete icon (or hit the “Del” key on the keyboard while the mouse is in the graphics window) to remove the viewport.

You will be asked to confirm the deletion.

17. Delete the second viewport you created as well.

See *How To Define and Change Viewports* (Help > How To Manual ...) for more information.
4.5 Parts and Part Attributes

Since virtually every task you perform in EnSight involves some form of part manipulation, it is vital to understand how parts work.

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or created during an EnSight session. Parts created during loading are called model parts. Model parts can also be created during an EnSight session by performing geometric operations (such as a copy) on other model parts.

All other parts are created during an EnSight session and are called created or derived parts. Created parts are built using one or more other parts as the parent parts. The created parts are said to depend on the parent parts. If one or more of the parent parts change, all parts depending on those parent parts are automatically recalcualted and redisplayed to reflect the change. Examples of created parts include clipping planes, isosurfaces, isocontours, and particle traces.

Only model parts will be used in this section. The next two chapters will work with created parts.

The Main Parts list provides access to all parts. Each part is listed individually in a scrollable list. Each entry provides a part descriptor (name) and three additional pieces of information:

- Part number (assigned by EnSight)
- Part type code (M indicates a Model part)
- Part Descriptor
- Select Part(s) To Operate On
- Case number

EnSight provides a large number of attributes that can be edited on a per-part basis. Attributes control the appearance or behavior of parts. Examples include visibility, color, line width, and transparency. Part attributes are typically edited in Part Mode. Some part attributes controlled through Part Mode icons also have a counterpart in a View Mode icon that acts as a global toggle for the attribute. For example, View Mode has an icon for hidden surface that enables/disables shaded surface display for all parts. Part Mode has a hidden surface icon that enables/disables shaded surface display on a per-part basis.

Many operations in EnSight (such as setting attributes) require that the parts to be acted on are selected (highlighted) prior to the operation. Items in the Main Parts list are selected by placing the mouse pointer over the item and clicking the left mouse button. You can extend a selection by pressing the shift key as you click an item. Additional techniques for selecting items in lists are discussed on page 3-10.

In the remainder of this section, we will explore parts and changing part attributes.
The last operation performed was to delete the two viewports we had created. If necessary, reset the transformations to return to the default view (as described on page 4-10).

The first task is to enable hidden surface (shaded) display. By default, the part-specific shaded attribute (as set in Part Mode) is on. By toggling on the corresponding Shaded toggle on the Desktop, we enable hidden surface display for all parts.

1. Click the Shaded Toggle on the Desktop to enable shaded surface display for all parts.

All objects in the Graphics Window are now displayed with shaded surfaces rather than the default wireframe. We can now selectively disable shaded display for individual parts.

2. Select the “green arrow” and “blue arrow” parts in the Main Parts list: place the mouse pointer over the green arrow part, click the left mouse button, and drag down until both parts are highlighted.

3. Click Part in the Mode Selection area to enter Part mode.

4. Click the Part Shaded Toggle to disable shaded surface display for the selected parts (you may have to scroll the vertical Mode Icon bar to reveal the icon).

Note that the Part Shaded Toggle icon changes (the wireframe side is now highlighted) to reflect the fact that the selected parts have shaded disabled.

Let’s change the line width of the selected parts:

5. Click the Part Line Width pulldown and select 3 Pixels from the menu.

Note that the line width of the selected parts (the arrows) has increased.

6. Select the “frame base” part in the Main Parts list.

7. Click the Part Visibility Toggle to disable display of the part.

After these operations, the geometry in your Graphics Display should look like the following.
Parts are assigned a default color when loaded into EnSight. These colors are constant, meaning that every portion of the part is colored the same. Parts can also be colored by a variable value. Since the value associated with a variable typically varies from node to node, the displayed color will vary across the surface of the part.

To change part colors:

8. Select all the parts in the Main Parts list: choose Edit > Part > Select All.

9. Click the Color icon in the Feature Icon bar. The Quick Interaction area for color opens. Note that the Color by menu is set to Constant Color.

10. Click the Mix... button to open the Color Selector dialog. Pick a shade of gray from the bottom row of the color palette and click Apply at the bottom of the dialog.

11. Click Close to close the Color Selector dialog. Note that all parts in the Graphics Window are now colored by the same shade of gray.

12. Although this dataset has no associated variable data, we can still color the parts by a variable since EnSight provides some defaults: Coordinates and Time. The Coordinates variable treats the XYZ coordinate of a node as a vector; color is assigned based on the magnitude of that vector.

13. Select (single-click) Coordinates in the Variables list.

14. In the Quick Interaction area, click Apply New Variable. Note the color change. The left rear post of the frame is closest to the origin of the coordinate system and is colored blue.

See How To Change Color (Help > How To Manual ...) for more information.
Up to this point, all parts have been selected by clicking in the Main Parts list. You can also select parts by picking them in the Graphics Window. Although this dataset contains only four parts, most geometries contain many more and selecting parts via the list can become tedious. To select parts by picking:

15. Move the mouse into the Graphics Window and place the pointer over the arrow on the left side of the model.

16. Press (and release) the ‘p’ key on the keyboard.

Look at the Main Parts list: the “green arrow” part (number 2) should now be the only part selected. (If this is not the case, be sure the mouse pointer is directly over one of the lines of the part and press the ‘p’ key again.)

17. Move the mouse pointer over the arrow on the right side of the model.

18. Press and hold the control key. With the control key still down, press and release the ‘p’ key.

Holding down the control key during the pick extends the current selection: both the “green arrow” and the “blue arrow” parts should now be selected in the Main Parts list. See How To Select Parts (Help > How To Manual ...) for more information.

If a dataset contains many parts, it can be difficult to determine which parts in the Graphics Window correspond to the parts selected in the Main Parts list. To display selected parts only:

19. Select View > Show Selected Part(s)... from the Main menu.

This opens a new graphics window (titled Selected Part(s) Window) that displays only the arrow parts.

20. Select View > Show Selected Part(s)... again to remove the window.

21. Click the Part Shaded Toggle to enable shaded surface display for the selected parts (you may have to scroll the vertical Mode Icon bar to reveal the icon).

22. Select the “frame base” part in the Main Parts list.

23. Click the Part Visibility Toggle to enable display of the part. EnSight can display node and element labels on selected parts. The label values are either provided explicitly from the dataset or are provided by EnSight. To display node labels:

24. Click the Node Label Toggle (you may have to scroll the vertical Mode Icon bar to reveal the icon) to enable node display for the “frame base” part.

See How To Display Labels (Help > How To Manual ...) for more information.
After these operations (and some rotate and zoom transformations) your Graphics Window should look something like the following. (Note that the node labels have been colored black here to contrast with the white background – your labels will be white on a black background.)
4.6 Using Online Help

EnSight 7 provides two types of documentation online:

**How To**
The How To documentation consists of relatively short articles that describe how to perform a specific operation in EnSight, such as change the color of an object or create an isosurface. Step-by-step instructions and pictures of relevant dialogs are included. In addition, each How To article typically contains numerous hyperlinks (colored blue) to other related articles (and relevant sections of the User Manual).

**User Manual**
The User Manual provides a detailed reference for EnSight.

Several documents are directly accessible from the main Help menu. The remainder can be accessed through hyperlinks, a table of contents, or an index. Most of the complex dialogs within EnSight have help buttons that will open a How To article. To open the How To table of contents:

1. Select Help > How To Manual...

The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc. Acrobat Reader provides much the same functionality as a World Wide Web browser while providing greater control over document content quality. The user interface is very simple and provides intuitive navigation controls.

Besides the use of Bookmarks for navigation, The following can be used:

- Clicking on the house icon will return you to the How To table of contents.
- Blue text is a link: clicking on it will jump to a new location.
- You can go back to the previously viewed page by clicking the back button (very similar to a Web browser).

The How To articles are heavily cross-linked and also provide links to relevant sections of the User Manual.

For more information on using Acrobat Reader (including printing) and the How To documentation, click on the question mark.
To access the *User Manual* table of contents:

1. Click the iconify button to close the Acrobat Reader window.
2. Select Help > User Manual... from the EnSight Main menu, then click “Table of Contents” on the title page.
3. The *User Manual* contains blue hypertext links just like the *How To* articles: you can click on items and jump to a new location:
   - chapter and section entries in the table of contents
   - index entries in the index
   - cross references in the text that begin “See ...”
   - the footer of every page will jump back to the title page of the User Manual (from which you can jump to any chapter).

### Printing the documentation

Adobe Acrobat .pdf files for all documentation are included on the EnSight CD distribution (and were placed in the SCEI_HOME/ensight76/doc/Manuals directory during the installation process). These documents (GettingStarted.pdf, HowTo.pdf, and UserManual.pdf) have been optimized for printing and formatted for letter-size paper. You can open these files and print any or all pages from within Acrobat, or you can send them out for printing.
4.7 Exiting EnSight

All EnSight actions have a counterpart in the EnSight command language. During a session, all actions are being recorded to a default command file. When you exit EnSight, you have the option of saving this command file.

To quit EnSight:

1. Select File > Quit... from EnSight’s Main menu. The Quit Confirmation dialog opens.

2. Click Yes to exit EnSight.

If you toggle on Save Command Backup File To and save the commands (for example, to a file called file.cmd), you could then start a subsequent Unix version EnSight session (from the same starting directory) with the command:

```
% ensight7 -p file.cmd
```

(assuming you are running stand-alone) to duplicate the entire session. You could accomplish the same thing by starting EnSight normally and then playing the command file from the command dialog (this would be the normal way to do it in the Windows version). See How To Record and Play Command Files (Help > How To Manual ...) for more information.

Note that the Quit Confirmation dialog also provides an option to save a “Full Backup Archive File”. An archive (which is saved for both the Client and the Server), contains a binary dump of the complete state of the system. Unlike replaying a command file (which has to re-execute every action), the restoration of an archive occurs very fast since only the saved state is restored. See How To Save or Restore an Archive (Help > How To Manual ...) for more information.
### 4.8 Where’s the Rest?

After successfully completing this tutorial, you should proceed to the next demonstration. Although the next tutorial contains some material applicable to all users, it is intended primarily for analysts doing computational fluid dynamics (CFD) work. If your application area is not CFD, you may wish to consider skipping the next chapter and proceeding directly to Chapter 5.

The How To Manual contains details on the operations covered in the chapter. The following online articles are relevant to the topics covered here.

*Note:* you get to these by selecting Help from the main menu, then How To Manual..., then the topic indicated below:

<table>
<thead>
<tr>
<th>Consult...</th>
<th>For More Information On...</th>
</tr>
</thead>
<tbody>
<tr>
<td>How To Read Data</td>
<td>specifying data to read into EnSight</td>
</tr>
<tr>
<td>How To Read <code>&lt;format&gt;</code> Data</td>
<td>reading the <code>&lt;format&gt;</code> built-in reader data format.</td>
</tr>
<tr>
<td>How To Rotate, Zoom, Translate, Scale</td>
<td>performing transformations in the Graphics Window as well as performing precise transformations using the Transformation Editor</td>
</tr>
<tr>
<td>How To Reset Tools and Viewports</td>
<td>resetting transformations back to the default settings</td>
</tr>
<tr>
<td>How To Define and Change Viewports</td>
<td>creating and editing user-defined viewports</td>
</tr>
<tr>
<td>How To Select Parts</td>
<td>selecting parts</td>
</tr>
<tr>
<td>How To Set Attributes</td>
<td>setting part attributes</td>
</tr>
</tbody>
</table>
Where's the Rest?
5 Flow Visualization Example: Unstructured Mesh

This chapter provides step-by-step instructions for performing many basic postprocessing operations – especially those relevant to computational fluid dynamics analysis. After successfully completing this chapter, you should be able to:

- create a clipping plane and display contours and vector arrows on the plane,
- move the clipping plane with the mouse (interactive clipping),
- create an isosurface and change the isovalue interactively,
- create a single particle trace and a rake of traces,
- move the rake of traces with the mouse (interactive particle tracing),
- animate particle traces,
- save an image of the Graphics Window to a file.
5.1 Starting EnSight

If you successfully performed the installation verification as described in *Verifying the Installation* on page 1-14, you have already started EnSight and connected the Client and Server. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type (stand-alone or distributed).

**Starting EnSight for Stand-alone Use**

If your installation of EnSight is stand-alone (*i.e.* the Client and Server are both running on the same workstation), you can use these simplified steps to start EnSight and *auto-connect* the Client and Server processes.

**For Unix Systems:**

You should be logged in to the console of the workstation on which the EnSight Client and Server have been installed. In addition the `CEI_HOME` environment variable, as well as your command search path, must be set up correctly as described on page 1-8.

1. Change to the directory containing the aerospace dataset. (The dataset contained in this directory will be loaded into EnSight in section 5.2.)
   
   % cd $CEI_HOME/ensight76/data/ami

2. Start EnSight using the `ensight7` shell script:

   % ensight7

**For Windows Systems:**

1. Choose EnSight7 from the Start > Programs > CEI menu.

   This will automatically start the Client and the Server and make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

   If the connection failed, please consult *Troubleshooting the Connection* on page 1-16 before contacting CEI support.

**Starting EnSight for Distributed Use**

If your installation of EnSight is distributed (*i.e.* the Client and Server are running on different computer systems), use the steps given below to start EnSight. Note that this operation is a *manual connection*. EnSight can be set up to perform the connection automatically. See *How To Connect Automatically* (Help > How To Manual ...) for details.

In the instructions that follow, `CLIENT_HOST` refers to the system on which the EnSight Client was installed and `SERVER_HOST` refers to the system on which the EnSight Server was installed.
The instructions also assume that the CEI_HOME environment variables as well as the command search path have been set up correctly as described on page 1-8.

For UNIX Systems:

1. Log on to the console of CLIENT_HOST and open at least two shell windows. Since the EnSight user interface will open on the right side of your screen, place the two shell windows on the left side.
2. In the first shell window, start the EnSight Client:
   
   ```
   % ensight7.client -cm
   ```
   
The `-cm` option tells the Client to begin listening for a connection from the Server. The EnSight Client user interface should appear on your workstation screen.
3. In the second shell window on your workstation, log on to SERVER_HOST:
   
   ```
   % telnet SERVER_HOST
   ```
4. In the second shell window, change to the directory containing the aerospace dataset. (The dataset contained in this directory will be loaded into EnSight in section 5.2.)
   
   ```
   % cd $CEI_HOME/ensight76/data/ami
   ```
5. In the second shell window, start the EnSight Server:
   
   ```
   % ensight7.server -c CLIENT_HOST
   ```
   
The `-c CLIENT_HOST` option tells the EnSight Server to connect to the EnSight Client listening on CLIENT_HOST.

For Windows Systems:

1. Log on to the CLIENT_HOST. Double click the ens6cl.exe icon located in the INSTALL_DIRECTORY\ensight76\machines\win32 folder.
2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.
4. Click the “Connect Server” button.
5. If the SERVER_HOST is a UNIX machine, follow steps 3 through 5 in the “For UNIX Systems” above. If the SERVER_HOST is a Windows machine, continue with these instructions.

Log on to the SERVER_HOST. Double click (or run, if you telnet to the machine) the ens7sv.exe icon located in the INSTALL_DIRECTORY\ensight76\machines\win32 folder.
6. In the resulting application console window, enter the name of the CLIENT_HOST machine.

The server should make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

If the connection failed, please consult Troubleshooting the Connection on page 1-16.
before contacting CEI support.

**Distributed Use - Automatic Connection**

You can perform an *automatic connection* where the Server starts automatically and connects to the Client, even though the two processes are on different host systems. This type of connection requires some initial setup and is not discussed in the *Getting Started* manual. However, once configured, the automatic connection lets you start a session in a single step. See *How To Connect Automatically* (Help > How To Manual ...) for details. (For information on the online help facility, see *Using Online Help* on page 4-20.)
5.2 Reading a Dataset

In this demonstration, we will load a simple CFD model of a hypersonic vehicle with an 8 degree angle of attack and a 6 degree side-slip. The dataset includes velocity and pressure values.

1. Select File > Data (Reader)... from the Main EnSight menu.

This opens the File Selection dialog.

For UNIX: Since we initially started EnSight (in the previous section) from the desired directory ($CEI_HOME/ensight76/data/ami), this directory is opened automatically (as seen in the Directories list).

For Windows: You will be in the machines\win32 directory. You need to go up two levels by twice double clicking on the .. directory, then go down to data, then the ami directory.

2. Click ami.case in the Files list.

3. Be sure the Format is set to Case (it is by default).

4. Click (Set) Case to set the casefile to the file currently selected in the Files list (i.e. ami.case).

5. Click Okay to accept the selections and close the dialog window.
When the File Selection dialog is closed, EnSight reads the file and opens the Data Part Loader dialog. During the initial read, EnSight determines the individual parts available in the file.

EnSight supports several different representations for parts. A part’s representation controls how it is displayed on the EnSight Client. The default representation is “3D Border, 2D Full” (which displays all unshared element faces for 3D data and all 2D elements). Another representation is “NonVisual” which essentially means that the EnSight Client has no graphical representation of the part at all. The NonVisual representation is most useful for flow field parts when you don’t really need to view the flow domain to postprocess the data, especially when the model is large and memory and CPU capacity are being stretched. See How To Change Visual Representations (Help > How To Manual ...) for more information on part representations.

6. Click to select the first part in the list, “external flow field”.
7. Click Element Visual Rep. and change the setting to “NonVisual”.
8. Click Load Selected.
9. Click to select the second part in the list, “ami-x hypersonic body”.
10. Click Element Visual Rep. and change the setting to “3D Border, 2D full”.
11. Click Load Selected.
12. Click Close.

The two constituent parts are now listed in the Main Parts list but only the hypersonic body part is displayed in the Graphics Window:

Note: To improve the legibility of the Getting Started manual, all images of the Graphics Window are shown with a white background rather than the default black background that EnSight uses.
5.3 Feature Demonstration

Unlike the dataset used in the previous chapter, this data contains two variables: pressure and velocity. The first step is to color the model by the pressure variable and display a color legend showing the mapping from variable values to color.

1. Select the “ami-x hypersonic body” part in the Main Parts list.

2. Click the Color icon in the Feature Icon bar to open the Quick Interaction area for Color.

3. Select pressure Variable.

4. Click Apply New Variable in the Quick Interaction area to color the selected part by the selected variable.

The color legend appears to the right of the model in the Graphics Window (default behavior that is a user-controllable preference). Note that the current display of legends can be controlled in the Legend Visibility dialog. We won’t actually modify the legend visibility at this time. Also note that color legends have many display attributes – see How To Create Color Legends (Help > How To Manual ...) for more information.

Change the display to hidden surface:

5. Click the Shaded Toggle on the desktop to enable shaded surface display for all parts.

Your Graphics Window should now appear as indicated.
In the next sequence of operations, we will create a new part: a clip using EnSight’s *Plane tool*. The Plane tool is a 3D icon in the Graphics Window that can either be manipulated with the mouse or moved precisely using the Transformation Editor.

Once the clipping plane has been created, we will build additional parts (a contour and vector arrows) using the clipping plane as the parent part.

6. Select the “external flow field” part in the Main Parts list.

7. Click the Clip icon in the Feature Icon bar.


9. Click Tool Location in the Quick Interaction area.

   This opens the Transformation Editor ready to manipulate the Plane tool.

10. In the Transformation Editor, make sure the Rotate icon is selected and change the Axis to Y.

11. Double-click the Increment field to select the “1.000000” value. Type “90” and press return.

   This will rotate the Plane tool 90 degrees about its Y axis. The tool should now be parallel to our line of sight (and perpendicular to the direction of flow).

12. In the Transformation Editor, select Editor Function > Global Transform (to return to global transforms rather than Plane tool transforms).

13. In the Transformation Editor, click Close.

14. Click Create in the Quick Interaction area to create the new clip part.

   Note that a new part “Clip Plane” is now listed in the Main Parts list.

   There is also a new part in the Graphics Window but you cannot see it since it is perfectly parallel to our line of sight: rotate the model to see the clipping plane.

15. Click Rotate icon in the Transformation Control area below the graphics window. Move the mouse pointer into the Graphics Window, click and hold the left mouse button and drag to rotate the model.

   By default, the clip plane is not confined to the bounds of the Plane tool – it extends to the edge of its parent part (the “external flow field”). You can, however, restrict the clip to the bounds of the Plane tool:

16. Click the Plane Extents button in the Quick Interaction area and change the value to Finite. The clip part automatically recalculates.
The new “Clip_plane” part listed in the Main Parts list has attributes just like the original model parts. For example, we can color the part based on the value of a variable and change other attributes as well.

17. Select the “Clip_plane” part in the Main Parts list.
18. Click the Color icon in the Feature Icon bar to open the Quick Interaction area for Color.
19. Select velocity in the variables list.
20. Click Apply New Variable in the Quick Interaction area to color the selected part by the selected variable.
21. Click the Part Shaded Toggle to disable shaded surface display for the selected parts (the “Clip_plane” part is still selected in the Main Parts list).

Your Graphics Window display should look something like the following:

The primary procedure in EnSight for creating new parts is as follows:
- One or more parts are selected in the Main Parts list (the parent(s)).
- A Feature is selected from the Feature Icon bar, below the main menu.
- If necessary, a variable is selected in the variables list.
- Desired changes are made to the Quick Interaction area for the selected Feature.
- The Create button is clicked in the Quick Interaction area to create the new part.
- Any desired attributes are set for the new part using Part Mode.
The clip plane was built using the external flow field as the parent part. Since the clip plane is itself a valid part, it can be used as a parent part to create other parts. To create contour loops of velocity on the clip plane:

22. Select the “Clip plane” part in the Main Parts list.

23. Click the Contour icon in the Feature Icon bar to open the Quick Interaction area for Contours.

24. Select Velocity in the variable list.

25. Change the value of the Sublevels field to 3 and press return.

26. Click Create to build the new contour part.

By default the Sync To Palette toggle is activated so that EnSight creates a contour loop at each level in the color palette assigned to the selected variable. Levels are evenly spaced values that span from the minimum to the maximum range of the variable. Default color palettes have five levels. The subcontour value sets the number of additional contour loops that will be calculated between each level. In this case, 17 total contours will be calculated: \((5-1)*3+5\).

The contour loops appears as white lines on the clip plane part. We can change the color and line width to make them more visible:

27. Click Color in the Feature Icon bar, select velocity, and then click Apply New Variable button in the Quick Interaction area to color the selected part (“Contour part”) by the selected variable (velocity).

28. Click the Part Line Width pulldown and set the width to 3 pixels.

Your Graphics Window should look something like:

See How To Create Contours (Help > How To Manual ...) for more information on contours and how color palettes affect contours.
Other parts can be created on the clip part as well. To place vector arrows at each node of the clip plane:

29. Select the “Clip_plane” part in the Main Parts list.

30. Click the Vector Arrows icon in the Feature Icon bar to open the Quick Interaction area.

31. Select velocity in the variables list.

32. Click Create to build the new vector arrow part.

33. If the vector scaling isn’t pleasing, you can get reasonable defaults by clicking Get Default.

By default, vector arrows are straight lines originating from the nodes of the parent part(s) and projecting in the direction of the local vector variable with length scaled by the Scale Factor value. Vector arrows have a number of styles controlling appearance.

34. Click Arrow Tips... in the Quick Interaction area to open the Vector Arrow Tip Settings dialog.

35. Change the Shape setting to Normal.

36. Change the Size to Fixed.

37. Click Close.

Experiment with other vector tip styles. See How To Create Vector Arrows (Help > How To Manual ...) for more information on vector arrows.

All clip parts in EnSight can be interactive: the tool that created the part can be grabbed with the mouse and moved. Once you release the mouse button, any parts that depend on the clip (i.e. that have the clip part as a parent), are automatically recalculated to reflect the new condition of the parent. So that the Plane tool can be easily manipulated, the hypersonic body will first be made invisible.

38. Click to select the “ami-x hypersonic body” in the Main Parts list.

39. Click the Part Visibility Toggle (in the Mode Icon bar) to disable display of the part.

The Plane tool can be manipulated with the mouse in several ways. In this example, the Plane tool will be translated. See How To Use The Plane Tool (Help > How To Manual ...) for details on manipulation.
40. Double-click the “Clip_plane” part in the Main Parts list.

Double-clicking a created part opens the Quick Interaction area for the part type and loads the part specific information. Any changes in the Quick Interaction area will affect only that part.

41. Change the Plane Extents value back to Infinite.

42. Click Interactive Tool in the Quick Interaction area.

43. Move the mouse into the Graphics Window and place the pointer directly over the center of the Plane tool (the place where the three Plane axes intersect).

44. Click and hold the left mouse button and drag the mouse left and right.

As the Plane tool is translated, the clip plane and vector arrow parts automatically recalculate and redisplay.

45. Release the mouse button.

The contour part now recalculates to reflect the ending location of the clip plane. You can also use the Transformation Editor to perform precise transformations on the tool.

46. Click Interactive Tool in the Quick Interaction area again to disable interactive operation.

Any kind of part (model or created) can be deleted. Note that a deletion cannot be undone.

47. Select all the created parts in the Main Parts list: place the mouse pointer over part 3, click the left mouse button and drag down until parts 4 and 5 are selected as well.

*Note: On some platforms (for example, HP) you cannot begin your click-drag select operation on a selected item. To select 3–5, first click to select item 2, and then perform the click-drag as described.*

48. Select Edit > Part > Delete (or simply hit the Delete button, or move the mouse into the graphics window and press the delete key) and confirm the deletion.

The parts are removed from the display and the Main Parts list.

49. Select “ami-x hypersonic body” in the Main Parts list.

50. Click the Part Visibility Toggle (in the Mode Icon bar) to enable display of the part.

51. Click the Plane Tool toggle on the Desktop to toggle off display of the Plane tool.
Another type of created part is an isosurface. An isosurface is a surface of constant value (the isovalue) in a 3D field. The region on one side of the isosurface has values greater than the isovalue and the region on the other side has values less than the isovalue. To create an isosurface:

52. Select the “external flow field” part in the Main Parts list.

53. Click the Isosurface icon in the Feature Icon bar to open the Quick Interaction area.

54. Select pressure in the variables list.

55. Double-click the Value field to select the “1.0” value.
   Type “0.9” and press return.

56. Click Create to build the isosurface part.

57. Click Color in the Feature Icon bar, then in the Quick Interaction area, select pressure in the variable list, and click Apply New Variable to color the isosurface part by pressure.

Note that the color of the isosurface (green) corresponds to the 8.6629e-01 level of the pressure color legend (which is close to our chosen isovalue of 0.9).

Isosurfaces can be interactive. Manipulating a slider changes the isovalue and the isosurface is recalculated and redisplayed.

58. Double-click the “Isosurface part” in the Main Parts list to open the Quick Interaction area for that part.


60. Grab the slider and move it left and right.
   The isosurface changes as the slider is moved.

61. Change the Interactive setting back to Off.

62. Select Edit > Part > Delete (and confirm the deletion) to remove the isosurface part.

See How To Create Isosurfaces (Help > How To Manual ...) for more information.
EnSight provides particularly powerful tools for exploring flow with particle traces. Traces can emitted from a point, a line, a plane, or even the nodes of an arbitrary part. A trace emitter can be made interactive: moving the emitter with the mouse will recalculate and redisplay the traces. In this example, a simple point trace will be created.

63. Click Reset... in the Transformation Control area and then click Reinitialize in the Reset Tools and Viewport(s) dialog to reset the model position. Click the Close button to remove the dialog.

64. Click the Cursor tool toggle on the desktop.

The Cursor tool is used to specify the position of a 3D point and, in this case, will be used to set the location of the particle trace emitter. Unfortunately, the Cursor is initialized to the origin of the coordinate system – which is currently inside the hypersonic body part. The part needs to be made temporarily invisible so the Cursor can be moved.

65. Select the “ami-x hypersonic body” part in the Main Parts list.

66. Click the Part Visibility Toggle to disable display of the part.

You should now see the Cursor tool (the red, green, blue cross) in the center of the screen.

67. Move the mouse pointer into the Graphics Window and directly on top of the center of Cursor tool.

68. Click and hold the left mouse button and drag the Cursor to a location up and to the left (see image below).

69. Click the Part Visibility Toggle to re-enable display of the hypersonic body part.

Your Graphics Window should look something like the following:
70. Select the “external flow field” part in the Main Parts list.

71. Click the Particle Traces icon in the Feature Icon bar to open the Quick Interaction area.

72. Select velocity in the variable list. The Emit From setting in the Quick Interaction area is set to Cursor by default.

73. Click Create to trace the particle. The trace should be visible extending from the Cursor tool to the right and down over the hypersonic body. See How To Use the Cursor (Point) Tool (Help > How To Manual ...) for more information on manipulating the Cursor tool.

EnSight can also trace from the Line tool to create a rake of particles.

74. Select Edit > Part > Delete to remove the particle trace part.

75. Select Tools > Cursor to disable display of the Cursor tool.

76. Select the “external flow field” part in the Main Parts list.

77. Select velocity in the variables list.

78. In the Quick Interaction area, change the Emit From setting to Line. This selection displays the Line tool which is also completely enclosed within the hypersonic body part.

79. Select the “ami-x hypersonic body” part in the Main Parts list.

80. Click the Part Visibility Toggle to disable display of the part. The Line tool (oriented horizontally) should now be visible.

81. Move the mouse pointer into the Graphics Window and directly on top of the center of the Line tool.

82. Click and hold the left mouse button and drag the Line to a location up and to the left.

83. Click the Part Visibility Toggle to re-enable display of the hypersonic body part.

84. Move the mouse pointer back into the Graphics Window and directly over the right end of the Line tool.

85. Click and drag the end of the Line tool down and to the left such that the Line is vertically stretched across the front of the hypersonic body (see image below).
86. Select the “external flow field” part in the Main Parts list.
87. If needed, re-select velocity in the variable list.
88. In the Quick Interaction area, change the # Points field to 12 and press return.
89. Click Create to create the rake of traces.

This operation created 12 evenly spaced traces along the Line tool.
Interactive particle traces are particularly useful for exploring fluid flow.
90. Click Interactive Emitter.
91. Move the mouse pointer into the Graphics Window and directly over the center of the Line tool.
92. Click and hold the left mouse button and drag the Line tool up and down. Release the mouse button.

The constituent traces are recalculated and redisplayed as the Line tool moves. It may help to rotate the model to a new orientation and then move the Line tool again.

Click Interactive Emitter again to disable interactive operation.

See *How To Create Particle Traces* (Help > How To Manual ...) for more information on particle tracing.
Particle traces can be animated to provide intuitive comprehension of flow characteristics. Traces are animated by displaying one or more tracers on all traces of the trace part. A tracer moves along the path of a trace with length proportional to the local velocity. EnSight provides complete control over all aspects of the tracers including length, speed, and release interval for multiple pulses.

93. Toggle Animate in the Quick Interaction area.

The tracers can be seen moving down the length of the traces. Numerous controls are provided for altering the appearance and behavior of the tracers.

94. Click Animate... to open the Trace Animation Settings dialog.

95. Click Get Defaults to load suitable default values to the various trace parameter fields.

96. Click Multiple Pulses.

Note that there are now several tracers are moving down each trace. The Pulse Interval field controls the spacing between tracers.

97. Double-click in the Pulse Interval field to select the value. Type “10” and press return.

98. Double-click in the Tracer Time field to select the value. Type “1” and press return.

99. Double-click in the Tracer Delta field to select the value. Type “0.3” and press return.

100. Click Close.

Animating traces often look better with the trace part invisible.

101. Click the Part Visibility Toggle to disable display of the particle trace part.

102. Select Tools > Line to remove the Line tool.

See How To Animate Particle Traces (Help > How To Manual ...) for more information on trace animation.
5.4 Saving Files

Saving Images

EnSight supports several formats for image output. In this example, both PostScript and Silicon Graphics RGB files will be saved.

1. Select File > Print/Save Image... to open the Print/Save Image dialog.

By default, SGI RGB is selected. To save the current contents of the Graphics Window:

2. Enter a file name in the To File field.

**Note:** By default, EnSight will save images in the directory from which the Client is started. Since this directory is part of the EnSight distribution, it is probably write protected. To save the image in your home directory instead, on a Unix system prefix the filename with "~/". On a Windows system, use "~\".

3. Click on Convert to Default Print Colors (changes background to white and white objects to black).

4. Click Okay.

For PostScript output:

1. Select File > Print/Save Image... to open the Print/Save Image dialog.

2. Click Format... to open the Image/Movie Format and Options dialog.

3. Select PostScript from the list.

   By default, EnSight saves PostScript using vector (move-draw) PostScript commands for optimal quality on high resolution printers. You can also save the entire scene in pixel PostScript. For example,

4. Change the Type setting to Image Pixels.

5. Click Okay to close the dialog.

If you have a PostScript printer accessible from your workstation, you can issue the print command and send the PostScript directly to the printer. Otherwise, you can output the PostScript to a file. To print direct to a printer:

6. In the Print/Save Image dialog, click the To File button to disable file output.

7. Click the To Printer Using Command button and enter your standard printer command but DO NOT include the file name. For example, if you usually print with `lpr -Plaser1 file.ps` then enter:

   `lpr -Plaser1`

8. Click Okay to print the image.

See How To Print/Save an Image (Help > How To Manual ...) for more information on image formats and options.
Saving Commands to a File

As seen in Exiting EnSight on page 4-22, EnSight supports a command language. Every action you can perform in EnSight has a counterpart in the language. In addition to saving all the commands for a session, you can save a short sequence of arbitrary actions for later use. These commands can be replayed during a subsequent session or attached to a keyboard key as a macro. To save a sequence of commands:

1. Reset the model: click the Reset... button in the Transformation Control area. Click Reinitialize in the Reset Tools and Viewports dialog and then click Close.
2. Select File > Command to open the Command dialog.
3. Toggle Record. The File Selection dialog opens.
4. Double-click on any part of the text in the Selection field to select it. Type “~/test.cmd” (or “~\test.cmd” in the Windows version), and click Okay.

The commands for actions you perform will be written to test.cmd in your home directory.

5. If you wish, perform some actions such as rotating and translating the model.
6. Toggle Record again to stop saving commands.

You can replay a command file as well.

7. Again, reset the model (as described in step 1, above).
8. Click Play to open the File Selection dialog.
9. Click in the right end of the Selection field, type “~/test.cmd” (or “~\test.cmd” in the Windows version), and click Okay.

Any actions performed prior to stopping the recording should be repeated.

10. Click Close to remove the Command dialog.

See How To Record and Play Command Files and How To Define and Use Macros (Help > How To Manual ...) for more information.
**Saving an Archive**

EnSight can also save the complete state of a session as an *archive*. An archive consists of two binary files containing the state of the Client and Server as well as an “Archive Information file” that stores additional information (including pointers to the two binary files).

Although you can duplicate a session by replaying a saved command file, restoring an archive is much faster. When you replay a command file, EnSight has to re-execute every action performed by the user, even if that action had no effect on the final state. An archive restores very fast since only the final state is restored.

To save an archive:

1. Select File > Save > Full Backup... to open the Save Full Backup Archive dialog.

![Save Full Backup Archive Dialog](image)

By default, EnSight will save the archive information file and the Client archive in the directory from which the Client is started. The Server archive will be saved on the Server host (by default, in the directory from which the Server was started). Since these directories are part of the EnSight distribution, they are probably write protected. To save the archive files in your home directory instead, prefix the entries with “~/*” (or “~\" if Windows version):

2. Click at the beginning of the Archive Information File entry and type “~/*” (or “~\" if Windows version).

3. Place the mouse pointer in the Client Directory field and double-click the left mouse button. Type “~/*” (or “~\" if Windows version).

4. Place the mouse pointer in the Server Directory field and double-click the left mouse button. Type “~/*” (or “~\" if Windows version).

5. Click Okay.

You can restore an archive during a session (either immediately after the Client-Server connection or after replacing a case) by selecting File > Restore > Full Backup.... You can also have an archive automatically load at startup. For a Unix system:

```
% ensight7 -ar ~/ensight0606_1519.archive
```

This can also be done from within the user interface, which is the normal way that it would be done with the Windows version. See *How To Save and Restore an Archive* (Help > How To Manual ...) for more information.
After successfully completing this tutorial, if you wish to work through an example utilizing a structured mesh, you should proceed to the next chapter. Otherwise, you might prefer to jump to Chapter 6 which presents a tutorial containing some material applicable to all users, but intended primarily for analysts doing structural mechanics (finite element) analysis.

The How To Manual contains details on the operations covered in the chapter. The following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual..., then the topic indicated below:

<table>
<thead>
<tr>
<th>Consult...</th>
<th>For More Information On...</th>
</tr>
</thead>
<tbody>
<tr>
<td>How To Read Data</td>
<td>specifying data to read into EnSight</td>
</tr>
<tr>
<td>How To Read &lt;format&gt; Data</td>
<td>reading the &lt;format&gt; data format.</td>
</tr>
<tr>
<td>How To Change Visual</td>
<td>element representations</td>
</tr>
<tr>
<td>Representations</td>
<td>color legends and the variable to color mapping</td>
</tr>
<tr>
<td>How To Create Color Legends</td>
<td>creating contours</td>
</tr>
<tr>
<td>How To Create Contours</td>
<td>creating vector arrows</td>
</tr>
<tr>
<td>How To Create Vector Arrows</td>
<td>manipulating the Plane tool</td>
</tr>
<tr>
<td>How To Use The Plane Tool</td>
<td>creating particle traces</td>
</tr>
<tr>
<td>How To Animate Particle Traces</td>
<td>animating particle traces</td>
</tr>
<tr>
<td>How To Print/Save an Image</td>
<td>printing or saving the image in the Graphics Window</td>
</tr>
<tr>
<td>How To Record and Play</td>
<td>recording and playing command sequences</td>
</tr>
<tr>
<td>Command Files</td>
<td>saving and restoring archives</td>
</tr>
<tr>
<td>How To Save and Restore an Archive</td>
<td></td>
</tr>
</tbody>
</table>
Where's the Rest?
6  Flow Visualization Example: Structured Mesh

This chapter is intended for users of structured mesh CFD software and those using the PLOT3D format to import data into EnSight. In addition, this chapter describes the use of the predefined CFD functions to compute variables derived from the fluid flow analysis. It is assumed that you have already worked through the features described in Chapter 4, flow visualization example for an unstructured mesh. After successfully completing this chapter, you should be able to:

- load a PLOT3D dataset
- create a part from a logical plane of the volume mesh
- create an IJK clipping plane
- use the predefined CFD functions
6.1 Starting EnSight

If you successfully performed the installation verification as described in *Verifying the Installation* on page 1-14, you have already started EnSight and connected the Client and Server. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type (stand-alone or distributed).

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (*i.e.* the Client and Server are both running on the same workstation), you can use these simplified steps to start EnSight and *auto-connect* the Client and Server processes.

For Unix Systems:

You should be logged in to the console of the workstation on which the EnSight Client and Server have been installed. In addition the CEI_HOME environment variable, as well as your command search path, must be set up correctly as described on page 1-8.

1. Change to the directory containing the aerospace dataset. (The dataset contained in this directory will be loaded into EnSight in section 6.2.)
   ```bash
   % cd $CEI_HOME/ensight76/data/plot3d
   ```

2. Start EnSight using the `ensight7` shell script:
   ```bash
   % ensight7
   ```

For Windows Systems:

1. Choose EnSight7 from the Start > Programs > CEI menu.

   This will automatically start the Client and the Server and make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

   If the connection failed, please consult *Troubleshooting the Connection* on page 1-16 before contacting CEI support.

Starting EnSight for Distributed Use

If your installation of EnSight is distributed (*i.e.* the Client and Server are running on different computer systems), use the steps given below to start EnSight. Note that this operation is a *manual connection*. EnSight can be set up to perform the connection automatically. See *How To Connect Automatically* (Help > How To Manual ...) for details.

In the instructions that follow, `CLIENT_HOST` refers to the system on which the EnSight Client was installed and `SERVER_HOST` refers to the system on which the EnSight Server was installed.
The instructions also assume that the `CEI_HOME` environment variables as well as the command search path have been set up correctly as described on page 1-8.

For UNIX Systems:

1. Log on to the console of `CLIENT_HOST` and open at least two shell windows. Since the EnSight user interface will open on the right side of your screen, place the two shell windows on the left side.
2. In the first shell window, start the EnSight Client:
   ```bash
   % ensight7.client -cm
   ```
   The `-cm` option tells the Client to begin listening for a connection from the Server. The EnSight Client user interface should appear on your workstation screen.
3. In the second shell window on your workstation, log on to `SERVER_HOST`:
   ```bash
   % telnet SERVER_HOST
   ```
4. In the second shell window, change to the directory containing the aerospace dataset. (The dataset contained in this directory will be loaded into EnSight in section 6.2.)
   ```bash
   % cd $CEI_HOME/ensight76/data/plot3d
   ```
5. In the second shell window, start the EnSight Server:
   ```bash
   % ensight7.server -c CLIENT_HOST
   ```
   The `-c CLIENT_HOST` option tells the EnSight Server to connect to the EnSight Client listening on `CLIENT_HOST`.

For Windows Systems:

1. Log on to the `CLIENT_HOST`. Double click the ens7cl.exe icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.
4. Click the “Connect Server” button.
5. If the `SERVER_HOST` is a UNIX machine, follow steps 3 through 5 in the “For UNIX Systems” above. If the `SERVER_HOST` is a Windows machine, continue with these instructions.

   Log on to the `SERVER_HOST`. Double click (or run, if you telnet to the machine) the ens7sv.exe icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
6. In the resulting application console window, enter the name of the `CLIENT_HOST` machine.

   The Server should make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

   If the connection failed, please consult Troubleshooting the Connection on page 1-16 before contacting CEI support.
Distributed Use - Automatic Connection

You can perform an *automatic connection* where the Server starts automatically and
connects to the Client, even though the two processes are on different host systems.
This type of connection requires some initial setup and is not discussed in the *Getting
Started* manual. However, once configured, the automatic connection lets you start a
session in a single step. See *How To Connect Automatically* (Help > How To Manual ...
) for details. (For information on the online help facility, see *Using Online Help* on
page 4-20.)
6.2 Reading a Dataset

In this demonstration, we will load a simple CFD model of the viscid, subsonic symmetric flow around a half-model of the shuttle orbiter. The dataset consists of the standard xyz (mesh) and q (results) PLOT3D format files.

1. Select File > Data (Reader)... from the Main EnSight menu.

This opens the File Selection dialog.

For UNIX: Since we initially started EnSight (in the previous section) from the desired directory ($CEI_HOME/ensight76/data/plot3d), this directory is opened automatically (as seen in Directories list).

For Windows: You will be in the machines\win32 directory. You need to go up two levels by twice double clicking on the .. directory, then go down to data, then the plot3d directory.

2. Click shuttle.xyz in the Files list.

3. Be sure the Format is set to PLOT3D.

4. Click (Set) Grid to set the geometry file to the file currently selected in the Files list (i.e. shuttle.xyz).

5. Click shuttle.q in the Files list.

6. Click (Set) Result to set the results file to the file currently selected in the Files list (i.e. shuttle.q).

7. Click Okay to accept the selections and close the dialog window.

When the File Selection dialog is closed, EnSight does not immediately read the file as in the previous example, but opens the Data Reader dialog for PLOT3D.

A number of different PLOT3D formats are supported by EnSight. For a complete description, see "How To Read PLOT3D Data" (Help > How To Manual ...) or "Reading PLOT3D Data Files" (Hep > User Manual ...). EnSight scans the PLOT3D files to determine which format is being used. In most instances this results in the correct settings but it may, however, be necessary to specify in the Data Part Loader if the PLOT3D files are iblanked, if they are ASCII, Fortran Binary or C Binary format, if multiple zones (blocks) are present and if the model is 2D or 3D. Upon making the appropriate settings, the files are read by selecting "Read Specified File":

Getting Started with EnSight 7
8. Click Read Specified File.

After the file has been read, the Data Part Loader dialog is opened. “Zone 1” appears in the Parts List indicating that one block of 3D cells has been found in the xyz (mesh) file.

9. Select “Zone 1” in the Parts List.

The logical indices of this selected zone appear in the "Using Node Ranges:" table.

The lower section of the Data Part Loader dialog is used to create PLOT3D parts, as parts are not specifically defined in this format. The most basic part is the fluid flow region, in this case 8-noded hexahedral cells surrounding the surface of the shuttle geometry. For reference, this single block will be named by typing in a Part Description before creating the part. A second part, defined by the surface of the geometry, will be created by choosing an appropriate limited range of nodes (which are normally known by the author of the PLOT3D mesh). In this manner any number of surface parts may be created in addition to the 3D (fluid) parts. Note that the Data Part Loader may be used at any time to create new parts from the original PLOT3D data files.

10. Click Element Visual Rep. and change the setting to "Feature Angle".

11. Type “external flow field”.

12. Click Create and Load Structured Part.

At this point the external flow field part will show up in the main part list and the feature angle representation of the domain will be displayed in the graphics window.
13. Change the "Using Node Ranges" to limit I indices to 1-54, leave the J indices at 1-63 and change the K indices to 1-1 (the geometry's surface).

14. Click Element Visual Rep. and change the setting to "3D border, 2D full".

15. Type “surface”.

16. Click Create and Load Structured Part.

17. Click Close.

The second created part now appears in the Main Parts list. The external flow field is displayed as a wire frame and the surface is displayed as a mesh. As the flow field and geometry are both symmetric, only a half-model was used. The image in your Graphics window should appear as follows:
6.3 Feature Demonstration

Unlike in the case of unstructured meshes as in the previous example, logical planes of a structured mesh may be viewed in addition to the arbitrary planes described using the plane tool. In this demonstration, constant I, J, and K planes will be created and used to display results.

First, change the display to shaded:

1. Click Shaded on the Desktop to enable shaded surface display for all parts.

After some rotations, translations, and a zoom - you should be able to produce an image approximately as follows:

(The model should be green)
2. Select the “external flow field” part in the Main Parts list.

3. Click the Clip icon in the Feature Icon bar to open the Quick Interaction area for clip creation.

4. Click the Use Tool button and change the setting to IJK.

5. Change the value for an I Mesh Slice to 48 and press return.

6. Click Create.

Notice that a new part appears in the Main Parts list, "Sweep surface".

7. Click the Color icon in the Feature Icon bar to open the Quick Interaction area for Color.

8. Select the Momentum variable.

9. Click Apply New Variable in the Quick Interaction area to color the selected part by the selected variable. (Note that the Sweep surface part remained selected after its creation)

The image in your graphics window should appear as follows:
As in the previous example, it is possible to interactively manipulate the clip plane. In this case, however, the plane will move along a given logical coordinate as the slide bar is used.

10. Double click the Sweep surface part to bring up the clip quick interaction area.

11. Select “Manual” from the Interactive menu.

12. Move the slider to view different constant I Mesh planes.

13. Change the Mesh Slice from "I" to "J" and "K" and use the slider to view different constant J and constant K mesh planes. Note that the Min, Max and Step settings can be used to limit the extent and resolution of these planes. Set the Mesh Slice back to “I” before continuing.

It is possible to use both IJK and arbitrary plane Clips within the same session of EnSight. The IJK Clip feature may also be used as an alternative to creating model parts via the Data Part Loader as described above.

Extended CFD Variables

Often, the primitive variables solved by a given CFD code are of less interest than certain derived variables, for instance the Mach number, defined as the ratio of the local fluid speed to the freestream speed of sound. In the aerospace community, a number of these derived quantities are referred to as the "PLOT3D functions", as they were available in the program PLOT3D. EnSight includes most of these functions, and enhances their original form in two important ways. First, these Extended CFD Variables may be computed based on the "q file" variables of the PLOT3D format, namely the scalars density and energy and the momentum vector. In this case, EnSight makes the appropriate mapping of the variables. If, however, PLOT3D files are not used, or if the PLOT3D variables are used in a non-standard fashion, the user may define the appropriate mapping between the variable names as they were defined in the results and those quantities needed by EnSight to create the desired extended variable. The second enhancement is the ability to define any value for the ratio of specific heats, Cp, or use a scalar variable to define a different Cp value at each node of the mesh.

14. In the Main Menu, Select Edit > Preferences..., then select Variables from the Preference list and click Modify Extended CFD Variable Settings....

This opens the Extended CFD Variable Settings dialog.

15. Click Show Extended CFD Variables.

16. Click OK.

You can also close the Preferences dialog.
The Variable list now contains the original variables as well as the Extended CFD Variables. As with all others, these variables will not be activated until they are needed, for instance to color a model part. The activation of the extended variables involve a computation requiring one or more of the primitive variables. This, in turn, will require their activation, which EnSight performs automatically. All activated variables will remain so until they are explicitly deactivated. Note also that some extended variables (for instance vorticity) involve complex computations which may require significant time to complete.

17. Click the Color icon in the Feature Icon bar to open the Quick Interaction area for Color.
18. Select the Mach variable (you will probably have to scroll to it).
19. Click Apply New Variable in the Quick Interaction area to color the selected part by the selected variable. (Note that the legend changed also.)

The image in your Graphics Window should look something like the following:

See *How To Create Variables* (Help > How To Manual ...) for more information.
After successfully completing this tutorial, you should proceed to the next demonstration. Although the next tutorial contains some material applicable to all users, it is intended primarily for analysts doing structural mechanics (finite element) analysis.

The How To Manual contains details on the operations covered in the chapter. The following online articles are relevant to the topics covered here.

*Note: you get to these by selecting Help from the main menu, then How To Manual..., then the topic indicated below.*

<table>
<thead>
<tr>
<th>Consult...</th>
<th>For More Information On...</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>How To Read PLOT3D Data</em></td>
<td>specifying PLOT3D format results data to read into EnSight</td>
</tr>
<tr>
<td><em>How To Create IJK Clips</em></td>
<td>creating clip surfaces in structured models</td>
</tr>
<tr>
<td><em>How To Create Variables</em></td>
<td>creating extended CFD variables</td>
</tr>
</tbody>
</table>
7 Structural Mechanics Example

This chapter provides step-by-step instructions for performing basic postprocessing operations – especially those relevant to non-linear dynamics (e.g. crash) analysis. Unlike the two previous datasets, the data used here is transient – it varies over time. EnSight provides a wide range of features for postprocessing and animating transient data.

After successfully completing this chapter, you should be able to:

- group multiple parts into a single part,
- show geometry displacements,
- probe for data values,
- change time steps,
- perform a query and plot it,
- add annotation to an image,
- create a flipbook animation.
Starting EnSight

If you successfully performed the installation verification as described in Verifying the Installation on page 1-14, you have already started EnSight and connected the Client and Server processes. The same operation will be performed here.

To start EnSight, execute the following instructions for your particular installation type (stand-alone or distributed).

Starting EnSight for Stand-alone Use

If your installation of EnSight is stand-alone (i.e. the Client and Server are both running on the same workstation), you can use these simplified steps to start EnSight and auto-connect the Client and Server processes.

For Unix Systems:

You should be logged in to the console of the workstation on which the EnSight Client and Server have been installed. In addition the CEI_HOME environment variable, as well as your command search path, must be set up correctly as described in page 1-8.

1. Change to the directory containing the crash dataset. (The dataset contained in this directory will be loaded into EnSight in section 7.2.)
   
   % cd $CEI_HOME/ensight76/data/guard_rail

2. Start EnSight using the ensight7 shell script:
   
   % ensight7

For Windows Systems:

1. Choose EnSight7 from the Start > Programs > CEI menu.

   This will automatically start the Client and the Server and make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

   If the connection failed, please consult Troubleshooting the Connection on page 1-16 before contacting CEI support.

Starting EnSight for Distributed Use

If your installation of EnSight is distributed (i.e. the Client and Server are running on different computer systems), use the steps given below to start EnSight. Note that this operation is a manual connection. EnSight can be set up to perform the connection automatically. See How To Connect Automatically (Help > How To Manual ...) for details.

In the instructions that follow, CLIENT_HOST refers to the system on which the EnSight Client was installed and SERVER_HOST refers to the system on which the EnSight Server was installed.
The instructions also assume that the `CEI_HOME` environment variables as well as the command search path have been set up correctly as described on page 1-8.

**For UNIX Systems:**

1. Log on to the console of `CLIENT_HOST` and open at least two shell windows. Since the EnSight user interface will open on the right side of your screen, place the two shell windows on the left side.
2. In the first shell window, start the EnSight Client:
   ```
   % ensight7.client -cm
   ```
   The `-cm` option tells the Client to begin listening for a connection from the Server. The EnSight Client user interface should appear on your workstation screen.
3. In the second shell window on your workstation, log on to `SERVER_HOST`:
   ```
   % telnet SERVER_HOST
   ```
4. In the second shell window, change to the directory containing the crash dataset. (The dataset contained in this directory will be loaded into EnSight in section 7.2.)
   ```
   % cd $CEI_HOME/ensight76/data/guard_rail
   ```
5. In the second shell window, start the EnSight Server:
   ```
   % ensight7.server -c CLIENT_HOST
   ```
   The `-c CLIENT_HOST` option tells the EnSight Server to connect to the EnSight Client listening on `CLIENT_HOST`.

**For Windows Systems:**

1. Log on to the `CLIENT_HOST`. Double click the ens7cl.exe icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
2. Bring the Connection dialog up, by File > Connect Server...
3. Change the “Type” to “Manual”.
4. Click the “Connect Server” button.
5. If the `SERVER_HOST` is a UNIX machine, follow steps 3 through 5 in the “For UNIX Systems” above. If the `SERVER_HOST` is a Windows machine, continue with these instructions.

   Log on to the `SERVER_HOST`. Double click (or run, if you telnet to the machine) the ens7sv.exe icon located in the `INSTALL_DIRECTORY\ensight76\machines\win32` folder.
6. In the resulting application console window, enter the name of the `CLIENT_HOST` machine.

   The Server should make the connection. To see if the connection is successful, you can click on the Info... button on the Desktop. You should see “Connection accepted” in the EnSight Message Window which comes up. Licensing information (licensee and expiration date) should also appear in the lower left corner of the Graphics Window. You should now close the EnSight Message Window and proceed to the next section.

   If the connection failed, please consult *Troubleshooting the Connection* on page 1-16 before contacting CEI support.
Distributed Use - Automatic Connection

You can perform an automatic connection where the Server starts automatically and connects to the Client, even though the two processes are on different host systems. This type of connection requires some initial setup and is not discussed in the Getting Started manual. However, once configured, the automatic connection lets you start a session in a single step. See How To Connect Automatically (Help > How To Manual ...) for details. (For information on the online help facility, see Using Online Help on page 4-20.)
7.2 Reading a Dataset

In this demonstration, we will load a transient dataset of a car crash into a guard rail. The dataset includes displacement and plastic strain values.

1. Select File > Data (Reader)... from the EnSight Main menu.
This opens the File Selection dialog.
For UNIX: Since we initially started EnSight (in the previous section) from the desired directory ($CEI_HOME/ensight76/data/guard_rail), this directory is opened automatically (as seen in the Directories list).
For Windows: You will be in the machines\win32 directory. You need to go up two levels by twice double clicking on the .. directory, then go down to data, then the guard_rail directory.

2. Click crash.geo in the Files list.
3. Set the Format to EnSight 5.
4. Click (Set) Geometry to set the geometry file to the file currently selected in the Files list (i.e. crash.geo).
5. Click crash.res in the Files list.
6. Click (Set) Result to set the results file to the file currently selected in the Files list (i.e. crash.res).
7. Click Okay to accept the selections and close the dialog window.
When the File Selection dialog is closed, EnSight reads the file and opens the Data Part Loader dialog. During the initial read, EnSight determines the individual parts available in the file and allows you to selectively load any or all parts.

8. Click Load All.
9. Click Close.

The constituent parts are now listed in the Main Parts list and displayed in the Graphics Window:

Note: To improve the legibility of the Getting Started manual, all images of the Graphics Window are shown with a white background rather than the default black background that EnSight uses.
7.3 Feature Demonstration

In many types of analysis, multiple parts are used to distinguish between various components or material types. To the extent allowed by the particular data format, EnSight maintains this distinction by assigning these entities to separate model parts. In some cases, however, this distinction is no longer useful for postprocessing. When manipulating objects in EnSight, you often want to apply the same attributes or operators to a group of parts. If the group is large, this process can become unwieldy. Fortunately, EnSight provides a mechanism, called grouping, for grouping multiple parts into a single group part. The original parts comprising the group will no longer be visible in the list.

In this example, we will group all parts associated with the car into a single part.

1. Select all the parts associated with the car: place the mouse pointer over the first part in the Main Parts list, click the left mouse button, and drag down until parts 1–12 have been selected.

2. Select Edit > Part > Group.

3. Enter “car” in the “Group Name?” prompt that appears.
   Note that parts 1–12 are removed from the list.

The interesting parts are now the four parts at the end of the Main Parts list: three parts for the guard rail and the new group part (named “GROUP: car”).
EnSight can displace geometry based on the value of a vector variable. Each displacement vector represents a translation of a node from its original position (an offset).

4. Select the three guardrail parts & the Group part.

5. Click the Displacement icon in the Feature Icon bar to open the Quick Interaction area for Displacements.

6. Select the displacement variable.

7. Click Apply New Variable.

Note the new positions of the car and the guard rail. See *How To Display Displacements* (Help > How To Manual ...) for more information.

Now color the car by the plastic strain variable.

8. Select the “GROUP: car” part in the Main Parts list.

9. Click the Color icon in the Feature Icon bar to open the Quick Interaction area for Color.

10. Select the plastic variable.

11. Click Apply New Variable in the Quick Interaction area to color the selected part by the selected variable.

The color legend appears to the right of the model in the Graphics Window. Color legends have many display attributes – see *How To Create Color Legends* (Help > How To Manual ...) for more information.

Change the display to shaded:

12. Click Shaded toggle on the desktop.

13. Rotate and zoom the model until the view in the Graphics Window looks something like the image on the next page.
EnSight provides an interactive probe tool that uses the mouse pointer to select points of interest.

14. Click the Probe icon in the Feature Icon bar to open the Quick Interaction area.

15. Select the plastic variable.

16. Change the Query to Surface Pick.

17. Move the mouse pointer into the Graphics Window and place the pointer over the car (preferably in a non-blue region). Click the “p” key on the keyboard.

The value of the plastic strain variable is calculated for the point under the mouse and displayed. A marker (the sphere) is also displayed.

18. Change the Query back to None.

See *How To Probe Interactively* (Help > How To Manual ...) for more information.
By default, EnSight initially displays the last time step. However, it’s easy to change timesteps.

19. Click the Solution Time icon in the Feature Icon bar to open the Solution Time Quick Interaction area.

The Solution Time Quick Interaction area provides several methods for working with time. Perhaps the easiest way to change time steps is to use the slider bar.

20. Place the mouse pointer over the slider bar. Click the left mouse button and drag the bar until the value in the Cur field is “12”.

21. Release the mouse button.

Note that the geometry in the Graphics Window has updated to reflect the data at the new time step. See How To Change Time Steps (Help > How To Manual ...) for more information.

EnSight provides powerful query and plot features. Query/plot is fully integrated with the transient data handling facility so that plots will automatically update during time changes. Here we will query for the maximum plastic strain over all timesteps.

22. Select the “GROUP: car” part in the Main Parts list.

23. Click the Query/Plot icon in the Feature Icon bar to open the Quick Interaction area.

24. Change the Sample setting to “At Maximum Over Time”.

25. Select the plastic variable for “Variable: 1”.

26. Click Create.

A new query entity appears in the Query Items list named “Maximum plastic vs. Time”. To plot the query:

27. Click the Plot tab.
28. Click New Plotter. The plot appears in the lower left corner of the Graphics Window. See *How To Query/Plot* (Help > How To Manual ...) for more information. Plot Mode provides control over the appearance of plotters and curves – see *How To Change Plot Attributes* (Help > How To Manual ...) for more information.

29. Since the axis interferes with the plot, simply click the axis toggle just above the graphics window off for now.

Your Graphics Window should now look something like the following:
7.4 Annotation

Many postprocessing tasks require the production of hardcopy (or video) output with various types of annotation. EnSight provides comprehensive features for annotation: text, lines/arrows, color legends, and bit mapped logos.

To add text annotation:

1. Click Annot in the Mode Selection area to enter Annotation mode.
2. Click the Text Creation icon to open the Text Annotation Creation dialog.
3. Click in the Text field and type “Car Crash”.
4. Click the New button to display the text in the Graphics Window.

This operation creates a new text object. The object is currently selected (as seen by the green handles). To move the text:

5. Move the mouse pointer into the Graphics Window and over the text. Click and hold the left mouse button and drag the text up. Release the button.

You can also resize the text.

6. Place the mouse pointer over the right-angle handle in the lower right corner (just below and to the right of the “h”).
7. Click and hold the left mouse button and drag the handle to the right to increase the size of the text.

EnSight supports several “special strings” that let you automatically display constant variable values as well as various internal values. For example, you can have a text string that displays the current solution time. When the time step is changed, the text automatically updates.

8. Highlight the “Car Crash” string in the Text field to select it.
9. Type “Time: ”.
10. Click to select Constant Variable in the Special String list.
11. Click to select Analysis_Time as the variable to use.
12. Click on the “1.00e+00” item to select the print format for the string.
13. Click the Insert Special String button to insert the special code into the Text field.
14. Click the New button to display the text in the Graphics Window.
15. Click Close to remove the dialog.

The text “Time:1.41e-01” appears in the Graphics Window. This value corresponds to the solution time at time step 12.
16. Move the mouse pointer into the Graphics Window and over the new text string.
17. Click and drag the text until it is under the “Car Crash” text.

Your Graphics Window should look something like the following:

If you change time steps (as described on page 7-10) or load a new flipbook (as we will do on page 7-16) the text will automatically update to reflect the current time.

See How To Create Text Annotation (Help > How To Manual ...) for more information.
As you have seen, EnSight can display color legends for any variable. You can also control the appearance of color legends in Annotation Mode.

Like other annotation objects, color legends have handles that you can grab to resize and reposition the object.

18. Move the mouse pointer into the Graphics Window and over the color bar area of the legend. Click and hold the left mouse button and drag the legend down slightly.

19. Move the mouse pointer over the upper right handle. Click and hold the left mouse button and drag down to shrink the vertical size of the legend.

You can also control the size and format of the legend text.

20. Click the Legend Text Size icon (you will have to scroll the vertical Mode Icon bar to reveal it) to open the Legend Text Size dialog.

21. Double-click in the size field to select the text, type “30” and press return.

22. Click the Close button to remove the dialog.

23. Click the Legend Text Format icon to open the Legend Text Format dialog.

24. Click to select the second item in the Format Selection list. Note that the variable labels have been reformatted. EnSight uses standard C language printf formats for floating point number display. You can enter your own custom format in the Legend Text Format field if you like.

25. Click the Close button to remove the dialog.

26. Click Part in the Mode Selection area and move the mouse pointer into the Graphics Window (to clear Annot Mode).
Your Graphics Window should look something like the following:

See *How To Create Color Legends* (Help > How To Manual ...) for more information.
7.5 Flipbook Animation

In many cases, dynamic phenomena can only be understood through interactive exploration as a transient dataset is animated. EnSight provides this capability in a transient flipbook. The process of creating a flipbook begins with an initial load. During this process, EnSight builds 3D graphics objects from the existing parts modified by the results at each time step. Once loading is complete, the objects can be replayed as fast as the graphics hardware permits while still allowing transformations (such as rotation).

To load a flipbook:

27. Click the Flipbook icon in the Feature Icon bar to open the Quick Interaction area for Flipbook Animation (you may have to scroll the Feature Icon bar to reveal the icon).

28. Be sure the Load Type is set to Transient.

29. Click Load to begin the loading process.

The Load Flipbook Status dialog displays the progress of the load. Once the load is complete, you can play the animation.

30. Change the Run Type to Auto.

31. Use the mouse to rotate the model while the animation is playing.

Note that both the plot and the time variable text update during playback. By default, the animation plays as fast as the graphics hardware permits. In some cases (for small models or very fast hardware), this can be too fast. To adjust the display speed:

32. Click Modify Run... to open the Auto Run Settings dialog.

33. Double-click in the Display Speed field, type “.5”, and press return.

A setting of .5 will run at half of full speed.

34. Click Close to remove the dialog and move the mouse pointer back into the Graphics Window to view the change.

35. When you are done viewing the animation, click Delete to remove the flipbook frames from memory.

See How To Animate Transient Data (Help > How To Manual ...) for more information. For greater animation control, EnSight also provides a keyframe animation system – see How To Create a Keyframe Animation (Help > How To Manual ...) for details.
7.6 Where’s the Rest?

The How To Manual contains details on the operations covered in the chapter. The following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual..., then the topic indicated below:

<table>
<thead>
<tr>
<th>Consult...</th>
<th>For More Information On...</th>
</tr>
</thead>
<tbody>
<tr>
<td>How To Group Parts</td>
<td>grouping parts into a single part</td>
</tr>
<tr>
<td>How To Display Displacements</td>
<td>displaying displacement variables on parts</td>
</tr>
<tr>
<td>How To Probe Interactively</td>
<td>probing interactively with the mouse</td>
</tr>
<tr>
<td>How To Create Text Annotation</td>
<td>creating annotating text</td>
</tr>
<tr>
<td>How To Create Lines and Arrows</td>
<td>creating annotating lines and arrows</td>
</tr>
<tr>
<td>How To Create Color Legends</td>
<td>displaying and modifying color legends.</td>
</tr>
</tbody>
</table>
Where's the Rest?
8 Where Do I Go From Here?

After completing the *Getting Started* tutorials, we suggest the following approach to learning EnSight:

1. Load one of your own datasets and practice the techniques presented here with your results. See Chapter 4, *Getting your Data into EnSight*, for information on existing interfaces.

2. Learn new features by using the articles in the *How To Manual* (Help > How To Manual ...). The *Table of Contents* (which is where you will be sent first, and the *Index* (accessed by a link on the bottom of each page) are good places to search for the topics you need. Clicking the Help buttons in the dialog windows is also a good way to find topics of interest.

**Support**

CEI provides comprehensive support services for EnSight. If you are evaluating EnSight for purchase or have an active support and maintenance contract, contact CEI Support at:

- Email: support@ensight.com
- Hotline: 800-551-4448 (U.S)
- 919-363-0883 (Non-U.S.)
- Fax: 919-363-0833

The support hotline is staffed from 8:00 AM to 5:00 PM EST except during U.S. holidays. If you are outside the U.S., please contact your local distributor of EnSight for support.

**Software Maintenance**

CEI is constantly working to improve both the quality and functionality of EnSight. New major releases are automatically shipped to all customers with an active support and maintenance contract. EnSight updates are available from CEI’s website:

www.ensight.com/products/downloads.html

Also see our website support page for Frequently Asked Questions, white papers, performance metrics, list of available readers/translators, and updated product information.

www.ensight.com/services/services.html

**Training**

Training courses are held regularly by CEI and in conjunction with CEI’s international distributors. Courses may be arranged at customer facilities. Contact your EnSight representative for details.
Index

A
animation
    flipbook 7-16
    keyframe 7-16
annotation
    color legend 7-14
    text 7-12
archive
    restore 5-20
    save 5-20

C
CEI Support 1-4, 2-2, 8-1
CEI_ARCH 1-8
CEI_HOME 1-8, 1-9, 1-10, 2-3, 2-4, 4-2, 5-2, 6-2, 7-2
CFD
    Structured Mesh Example 6-1
    Unstructured Mesh Example 5-1
Clip
    interactive 5-11
    unstructured model 5-8
clip
    IJK 6-8, 6-9
    interactive 6-10
color
    legend 5-7, 7-8, 7-14
    part 4-17
command file 4-22, 5-19
connection
    troubleshooting 1-16, 2-10
Contour 5-10
Contour part creation 5-10
Cursor tool 5-14

D
Data - Getting it into EnSight 4-7
dataset
    PLOT3D, reading 6-5
    reading 4-5, 7-5
    unstructured dataset reading 5-5
Desktop 3-2
displacement (part) 7-8
distributed
ex    execution 1-14, 2-8
distributed process execution
    automatic connection 4-4
    starting 4-2
documentation 4-20
    printing 4-21

E
EnSight
    quitting 4-22
    starting 4-2
    support 1-4, 2-2, 8-1
    supported platforms 1-3
    training 8-1
EnSight Hot Keys 4-12
ENSIGHT7_INPUT 1-8
ENSIGHT7_MAX_CTHREADS 1-9
ENSIGHT7_MAX_SOSTHREADS 1-9
ENSIGHT7_MAX_THREADS 1-9
ENSIGHT7_READER 1-8
exiting EnSight 4-22

F
Feature Icon Bar 3-3
flipbook animation 7-16
Function Key Usage 4-12

G
Getting Your Data Into EnSight 4-7
Graphics Window 3-2, 3-7
grouping 7-7

H
Hot Keys 4-12
How To (online documentation) 4-20

I
image save 5-18
install (shell script) 1-6, 1-7, 2-3
installation
    license manager 1-11, 2-5
    requirements 1-1, 2-1
    troubleshooting 1-13, 2-7
    verification 1-14, 2-8
interactive probe 7-9
Isosurface
    interactive 5-13
Isosurface part creation 5-13

L
license key 1-10, 2-4
Line tool 5-15

M
Main Menu 3-2
Index

Main Parts List 3-2, 3-3, 4-15
Main Variables List 3-2
Message Area 3-2
Mode Icon Bar 3-2, 3-6
Mode Selection Area 3-2, 3-5

N
node labels 4-18

O
online documentation 4-20
printing 4-21

P
part
attributes 4-15
color 4-17
created 4-15
displacement 7-8
list 3-3
node labels 4-18
parent 4-15
picking 4-18
representations 5-6
selection 3-10
visibility 4-16
Particle Trace
animation 5-17
interactive 5-16
part creation 5-15
Particle Traces 5-14
path variable (UNIX command search path) 1-8
Plane tool 5-8
printing documentation 4-21
probe, interactive 7-9

Q
Quick Interaction Area 3-2, 3-5
quitting EnSight 4-22

R
rotate 3-6, 4-9

S
saving
archive 5-20
command file 4-22, 5-19
images 5-18
Simple License Manager 1-10, 2-4
installation 1-11, 2-5
slim7.key 1-10, 2-4
stand-alone
execution 1-14, 2-8
stand-alone execution
starting 4-2
starting EnSight 4-2
Status History Area 3-2
Support 1-4, 2-2, 8-1

T
timestep, changing 7-10
training 8-1
Transformation Control Area 3-2, 3-6
transformations
precise 4-11
reset (clear) 4-10
rotate 3-6, 4-9
translate 3-6, 4-9
zoom 3-6, 4-9
translate 3-6, 4-9

U
User Manual (online documentation) 4-20

V
variables 5-7
creation from structured CFD data 6-10
Vector Arrow part creation 5-11
viewport
create 4-13
delete 4-14
resize 4-14

Z
zoom 3-6, 4-9